• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Image flattened when exporting to Photoshop

Community Beginner ,
Feb 20, 2010 Feb 20, 2010

Copy link to clipboard

Copied

Me again!! Not sure if this should go under Photoshop or Illustrator, but whenever I export an image to Photoshop it gets flattened and I can't do anything with it. I've checked and double checked that Write Layers, Max Editability etc is ticked but then I get a box saying "some containers in AI have been flattened". Advice in basic English please!!!

Views

34.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Contributor , Feb 21, 2010 Feb 21, 2010

I think you are seeing two separate issues.

First, the illustrator is not exporting your layers because you have transparent elements. When it encounters transparency, it flattens everything below that object.

Second is if you are doing copy and paste between illustrator and photoshop: you need to paste as a smart object. If you don't have that as an option, your illustrator clipboard preferences might need changing [Illustrator:Preference…:File Handling and Clipboard:Set copy as to PDF].

You may w

...

Votes

Translate

Translate
New Here , Aug 27, 2014 Aug 27, 2014

Yes, getting rid off "Overprint Fills" really helps. BUT BE SURE!, that you get rid off all transparencies in the file. Hitting CMD+A and switching off "Overprint Fills" (on the Atributes palette) MAY NOT WORK inside groups and masks. You have to find that specific object, that causes problem. HINT: Layer that contains objects with "Overprint Fill" flattens all layers below it, so start looking below the last unflattened layer. (...it took me only about an hour to find this simple thing out)

Votes

Translate

Translate
LEGEND ,
Feb 20, 2010 Feb 20, 2010

Copy link to clipboard

Copied

Illustrator tries to maintain the layers etc. It does not guarantee it will.

So it depends on what you have in your file. It would be nice to see the a screen shot of the file in PS with the layers panel

you might not want to show the whole image because of your copyright but you can place the layers panel on top of the image
so it obstructs part of it. Just show enough of it so we can tell what is going on.

You may have no choice in some cases except to copy and paste from PS to AI.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 20, 2010 Feb 20, 2010

Copy link to clipboard

Copied

OK. I've attached a screenshot of the Photoshop window. Although the Layers Panel shows Layer1 + layer 2, I can't open them. Sorry if the screenshot is rubbish - it was my first ever attempt.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 20, 2010 Feb 20, 2010

Copy link to clipboard

Copied

You only have one layer they have ben merge into one layer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 20, 2010 Feb 20, 2010

Copy link to clipboard

Copied

That's my problem. In Illustrator, I have 2 layers - each with their own groups, paths etc. but when I export the image to Photoshop the image gets flattened and all the layers become ONE uneditable layer. As in my original post, I have ensured that the boxes "Write Layers" and "Max Editability" are ticked, but then I get a window saying some containers have been flattened. I don't know why.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 20, 2010 Feb 20, 2010

Copy link to clipboard

Copied

Oh I see I misunderstood.

Again what you might have to do is copy or paste or better yet place it in Photoshop as a smart object,

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2010 Feb 21, 2010

Copy link to clipboard

Copied

OK. So I've tried copy/paste and also placing but the results are always the same - the layers just get merged into one layer that I can't do anything with.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 21, 2010 Feb 21, 2010

Copy link to clipboard

Copied

So let me get this correctly…you made a photoshop document with two layers, you copy one layer in Illustrator and you pasted it into Photoshop on ne of the layers and then you copied the other layer in Illustrator and pasted that in the second layer in Photoshop and they automatically merged?

Is that correct!

I have to admit I never heard of this happening before.

I'm puzzled.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2010 Feb 21, 2010

Copy link to clipboard

Copied

No. I created an image with lots of layers in Illustrator and copied and pasted the whole thing into Photoshop, but instead of all the layers showing up in Photoshop I only get ONE merged layer which is uneditable. I get the same result when I Place or Export.

I read somewhere that this happens if you have lots of nested layers, but none of my layers are nested.

My reason for going from Illustrator to Photoshop is because I want to enhance the brightness and contrast on SOME of the layers in the image.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 21, 2010 Feb 21, 2010

Copy link to clipboard

Copied

I think you are seeing two separate issues.

First, the illustrator is not exporting your layers because you have transparent elements. When it encounters transparency, it flattens everything below that object.

Second is if you are doing copy and paste between illustrator and photoshop: you need to paste as a smart object. If you don't have that as an option, your illustrator clipboard preferences might need changing [Illustrator:Preference…:File Handling and Clipboard:Set copy as to PDF].

You may want to copy and paste your layers individually to photoshop. It can help to have an extra (invisible) path to help align things in photoshop (just a rectangle at the top left can usually do it, or a frame around the whole thing).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 21, 2010 Feb 21, 2010

Copy link to clipboard

Copied

Ah hah!!! That'd be it then - the transparencies!! My whole image is made up of transparencies. Oh well nevermind. Thanks for your help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 21, 2010 Feb 21, 2010

Copy link to clipboard

Copied

Try that: Target each top layer and Enable KnockOut Group option in the transparency panel before exporting to PSD. You may also try the Isolate Blending option. Maybe this will allow you to export and preserve the top layer structure. But It might introduces some discrepancies between what you see in Illustrator and the exported PSD.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 25, 2010 Feb 25, 2010

Copy link to clipboard

Copied

IF . . . you have a copy of Freehand MX, one way of retaining layers when exporting from AI (CS3) to PS (CS3) is:

Save Illustrator document as Illustrator 8 file.

Open exported .ai file in Freehand MX (you should see all your layers in the Freehand document).

Export from Freehand to Photoshop 5 format selecting "Include Layers" checkbox in Setup.

Voila.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 19, 2010 Apr 19, 2010

Copy link to clipboard

Copied

I've tried your suggestion with the transparencies and Knockout Group but it still doesn't work. What Illustrator does is export the 1st 8 layers perfectly fine, then flattens the last 8 layers into 1 Photoshop layer. Is there a max # of layers when exporting to Photoshop from Illustrator?

I'm using CS4 and I can't remember ever having this problem with CS3.

Any help would be greatly appreciated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 20, 2010 Apr 20, 2010

Copy link to clipboard

Copied

I don’t think there are any limits. Bet you’ve got something on that 8th layer that is doing something that invokes transparency. Look for overprint, shadows… things like that.

Try removing the layer or objects until you find it.

Good luck!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2014 Aug 27, 2014

Copy link to clipboard

Copied

Yes, getting rid off "Overprint Fills" really helps. BUT BE SURE!, that you get rid off all transparencies in the file. Hitting CMD+A and switching off "Overprint Fills" (on the Atributes palette) MAY NOT WORK inside groups and masks. You have to find that specific object, that causes problem. HINT: Layer that contains objects with "Overprint Fill" flattens all layers below it, so start looking below the last unflattened layer. (...it took me only about an hour to find this simple thing out)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2015 Aug 06, 2015

Copy link to clipboard

Copied

This worked for me fully! Thanks. Tried everything in the thread until this solution worked. Yes.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 26, 2015 Sep 26, 2015

Copy link to clipboard

Copied

Thanks heaps, alojs, this worked for me. I hit command+A and unchecked Overprint Fill in the Attributes panel. Problem of uwanted merged layers was solved.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 21, 2016 Dec 21, 2016

Copy link to clipboard

Copied

This did the trick for me. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 07, 2011 May 07, 2011

Copy link to clipboard

Copied

Man, you guys are something else. Don't export the Illustator document to an open file in Photoshop. Just open Photoshop and hit open and select the name of the file in Illustrator you want to export to Illustrator. That's it. All layers should show up in Photoshop. Then do what ever you want with them.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 07, 2011 May 07, 2011

Copy link to clipboard

Copied

You are correct should should show up but not guaranteed, is that correct?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 07, 2011 May 07, 2011

Copy link to clipboard

Copied

Yeah, I just tried it and had problems but tried it again and it worked. A layers came up in photoshop. 

Ronnie 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 07, 2011 May 07, 2011

Copy link to clipboard

Copied

Sorry for the typo  about. It should read " select the name of the file in Illustrator you want to export to Photoshop." 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 18, 2014 Mar 18, 2014

Copy link to clipboard

Copied

I know this issue is long since resolved, but because I encountered it myself today, and found my way to this forum seeking help, I thought I'd add the solution that worked for me -

I have hundreds of layers in my AI (CS5.5) file - Typically, Export as PSD with Write Layers enabled (+ Maximum Editability / Preserve Text) renders a large file that Photoshop interprets properly, with all text in tact and fully editable - Today however, that wasn't the case: my exported PSD opened as one large flat and transparent graphic - not good when sending out to our developers for slicing / CSS - Definitely did not want to spend the additional time copying, pasting and styling all my text layers over again -

Followed some of the recommended steps above - After individually deleting each of the complicated / potentially problematic layers (eg., clipping masks of grouped objects, transparent objects, etc.), it turns out the solution that worked was to:

First convert any Spot Colors in the swatches palette to Process. Then Export to PSD.

OR

Even easier, simply disable "Embed ICC Profle" from the PS Export Options dialog. 

Not sure why, but this worked instantly: all my AI layers are now inside one layer group in PS - including the suspected transparency objects and my clipping masks - Didn't notice any color shifts either - good luck

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 23, 2014 Jul 23, 2014

Copy link to clipboard

Copied

Thanks,

This problem has been haunting me for a while. my latest trick is to copy and delete transparent groups, or groups with spot colors, export to PSD, then paste in place the trouble groups into the AI file and the PS file.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines