• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Pantone colors are printing blank when printing from Illustrator using Photoshop DSC.EPS

Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

While trying to print artwork with spot colors from Adobe Illustrator the color in the 2nd channel will always print blank regardless of what print device or setting that is used. I have included the DSC EPS files as well as the AI files and the subsequent print of the file as a pdf. Whichever pantone color is placed in location 2 of the channels in Photoshop will print blank. This is a bug that has popped up since Pantone pulled it's colors from Adobe and the Pantone colors automatically are changed to black.

 

Below is how the Ai file looks:

 

AiFile.JPG

Below is how Pantone 7500 prints out. Notice how it prints blank with it placed in channel 2 of photoshop. Same file, same spots colors, just a different location in Photoshop. 

 

Pantone 7500.JPG

Below is how Pantone Warm Red prints out. Notice how it prints blank with it placed in channel 2 of photoshop. Same file, same spots colors, just a different location in Photoshop. 

Pantone Warm Red.JPG

Below is how the channels look in Photoshop (warm red C prints blank in this case):

 

ChannelLocation.JPG

 

For some reason channel 2 is printing blank. It does not matter which color is placed there anything in channel 2 will not print.

 

Now here's the crazy part. I've had this happen to 8 different files I've opened recently, but the location that does not print changes for each of them. Sometimes it's channel 2, sometimes it's channel 6. The only fix has been to rebuild the file by making a new file and manually copying the channels over one by one, and (very important) you have to not use official Pantone color names or pantone pickers in Photoshop. It has to be named something not PANTONE and has to be a hex color.

 

I believe this bug has something to do with the conversion process of pantone colors being changed to black if you don't have the pantone colors installed as it's happening with existing files that used pantone colors via the color picker. If it was created with hex values the issue doesn't seem to happen. The big bummer part is just changing the pantone colors and names after Adobe makes the conversion does not work. You have to rebuild it from a new file or the bug will still keep happening. This means all old files using Pantones will have to be rebuilt in order to print them properly. There must be something saved in the channel info that is still saying it is/was a Pantone color even after changing it to a different color or name.  

 

I've had 8 printers call me in the last two days that have been having this issue with screens printing blank for spot colors. This is going to become a massive issue if it's not fixed before they do the full update that will no longer have any of the pantone colors available. 

 

EDIT: It won't let me attached the Ai file for some reason. But you can infer from the pdf and EPS files that are included. View the EPS files in Photoshop not Illustrator. 

TOPICS
Bug

Views

191

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Nov 02, 2022 Nov 02, 2022

Ok I've fully figured out the bug and what is causing it. Adobe illustrator has default names for Pantone swatches. If you use the default name for the channel name in photoshop the swatch will automatically update it to the Pantone swatch on file in Illustrator's color book regardless of the color you picked in Photoshop manually. The issue arises when the default name is not on file (and they all won't be once Pantone color support is dropped without a subscription). In my case it was "PANTONE

...

Likes

Translate

Translate
Community Expert ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Seems to work fine with a CMYK file with spot channels saved as .psd.

Placed into Illustrator it separates fine. Why eps?

Attached a pdf with Illustrator editing enabled.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

These are for color separations. Using the CMYK PSD file prints 4 blank plates as there are technically no CMYK colors just spot colors. I would use PSD but unfortunately Illustrator does not support multi channel PSD files. If they did I wouldn't need to use DCS EPS. The option to use PSD would work if it didn''t print 4 blank pages. Granted you could turn off those colors in Illustrator before printing but I can't tell you how many calls I've gotten from printers asking why they are getting four blank plates. People want things easy, hit print and it prints. We shouldn't have to uncheck 4 boxes everytime because Adobe doesn't have multi channel support and EPS DCS is now bugged because of Pantone's changes.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Just tried it with your channels eps file and that works too.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

You linked the .eps file I provided into Illustrator and thats's what printed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

OK I'm not sure why but it will not let me upload the ai file I made. Here is a drop box link of it. https://www.dropbox.com/s/ap2vkpd2mkfvd68/2nd%20Channel%20Printing%20Blank.ai?dl=0

 

If you download that and relink the eps files you should get the same result I got when outputing as host based separations. I've tried this on multiple computers. Same results. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Can you please send me the ai file you used to make that epsfile.pdf using my channels eps file?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Here is the .ai file, your files is linked.

https://shared-assets.adobe.com/link/4ef96397-fe5d-4431-6bba-3de70648dfa3

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Ton,

Thanks for your help. Your Ai file appears to work but when I create a new file on my system it does not work. Please watch this quick 4 min video to show you what I mean. I'm hoping you might have an idea as to why files created on my system will not work but the Ai file you provided will. 

 

https://www.youtube.com/watch?v=U3fqrGO5B24

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

I did some more testing with your Ai file. If I copy the eps files from your document and then paste them into my existing document that I created that already had the eps files in them I get a color swatch conflict for the two colors in channel slot 2 (see below video) even though they are the exact same linked file. So it looks like for whatever reason my system is loading the eps file swatches differently into Illustrator than your system is causing the bug. I just can't figure out what is causing the swatches to be different for identical files. 

 

 https://youtu.be/tD7t8f_d2a0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Oh I should also ask do you have the pantone subscription 3rd party app installed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

No app installed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

Yeah just checked again to see if the built in reg marks made a difference. It still prints channel 2 blank. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 01, 2022 Nov 01, 2022

Copy link to clipboard

Copied

And I just checked with both of your eps files placed in a single .ai file, and that worked too.

I use the most recent AI version 27.0

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

I've figured it out.  Thanks for the assist as I would have not been able to figure this out without you as my system was loading the swatches in a way that did not allow them to print. Seeing your file gave me some insight into what was happening so I could figure it out.

 

To fix it the swatch options must be in color mode:  RGB, HSB, or LAB. Using the color mode CMYK resulted in the channel printing blank. Maybe it has something to do with the pantone color falling outside of that color gamut so it errors? Regardless Adobe might want to address this as the color mode used in the switch should not matter if it's labeled as a spot color since it's output in grayscale anyway. It also shouldn't default to swatch names and overwrite existing color data, but that's not a big problem as you can name it whatever you want. Below's a video of the fix. 

 

https://youtu.be/c2xJDtRjmaI 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Ok I've fully figured out the bug and what is causing it. Adobe illustrator has default names for Pantone swatches. If you use the default name for the channel name in photoshop the swatch will automatically update it to the Pantone swatch on file in Illustrator's color book regardless of the color you picked in Photoshop manually. The issue arises when the default name is not on file (and they all won't be once Pantone color support is dropped without a subscription). In my case it was "PANTONE 2156 C". If you check the default Pantone color books in Illustrator currently this color is not included, so what happens is Illustrator reads the swatch name sees it's called a Pantone color but can't locate the book color info for it. Instead of stating the color book is missing it displays as the original swatch color and reads it as a CMYK value, but Illustrator still thinks its a Pantone color. The result when you print is whatever spot color is placed below that unidentified spot color, ie "PANTONE 2156 C" does not print. It just prints blank. If I move the ""PANTONE 2156 C" to location 2 the 3rd spot prints blank, if I move it to location 4 the 5th spot prints blank. This explains why I was seeing this happen across multiple files but in different channel locations each time. The fix is to change the unidentified Pantone color swatch color mode option to RGB, LAB or HSB mode. CMYK mode can be used for spot colors normally but not when ANY of the swatches have an official PANTONE color name in the file. For some reason naming a swatch PANTONE that is not in the existing color book on that system is defaulting it to CMYK mode and causing the following color in the file to print blank.

 

A quick fix by Adobe could be to default PANTONE missing colors to RGB/LAB mode for all swatches when they are missing. I really hope they can fix this before Pantone drops full support and we lose all of the official color books otherwise all previous files that used pantone colors will have this issue when trying to reprint them. 

 

I made a video showing what I mean.

 

https://youtu.be/Vr2Ok1qQ7zE

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

You may want to mention it here:

https://illustrator.uservoice.com/

It should not matter what color mode is specified for a Spot color to separate correctly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Yeah I posted it there last night if you'd like to help out with a vote for more awareness https://illustrator.uservoice.com/forums/601447-illustrator-desktop-bugs/suggestions/45917158-panton...

 

What I'm still wondering is why your color swatch for Pantone 2156 C defaulted to RGB when you linked it to your file but mine defaulted to CMYK when I linked it to mine. Did you happen to change it manually to RGB or did it just load in like that. I might be able to pre-empt the issue if I figure out why it's defaulting to a CMYK color on my system but not yours. I tried changing the document color mode and seeing if the last made swatch color mode mattered but it had no effect. Still creates it as CMYK, which like you said should work but doesn't if it has the name of a pantone color that is not in the color book. Thanks again for your help. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

The Pantone 2156 C that defaulted to RGB instead of Lab is the only one that I don't have in my Pantone Library (and does not show Book Color). No changes done from my side.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

LATEST

Voted!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines