Illustrator Running slow on 2019 macbook pro

Community Beginner ,
May 14, 2021 May 14, 2021

Copy link to clipboard

Copied

Hey All,

 

I'm sure this is a popular topic as I've read many postings but still havent found a solution. 

There is a 3-4 second lag in just about every movement I make in Illustrator and it makes me want to throw my computer out the window. The file I am working on is 2.8MB in size and is mostly basic black/white vector shapes with a few small embedded .jpgs. 

 

Here is some information I hope helps troubleshoot:

 

MacBook Pro 15 inch 2019

2.3GHz i9

16GB RAM 

Radeo Pro 560X

MacOS 10.15.7

Illustrator 24.3

 

 

TOPICS
Performance

Views

382

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 15, 2021 May 15, 2021
Does this happen with other files as well? Is the Dictation Service in the system turned off?

Likes

Translate

Translate
Adobe Community Professional ,
May 15, 2021 May 15, 2021

Copy link to clipboard

Copied

Does this happen with other files as well?

 

Is the Dictation Service in the system turned off?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Hi Monika,

 

Yes, Dictation is turned off. 

I realized it's unique to this file. I wonder if it's corrupted. What's the best resolution to this? Copy a few elements at a time over to a new file to try and isolate the corrupt element? 

 

Thanks,

 

Ahren

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Solved! I moved individual components to another document to figure out which shape was causing the issue. Luckily it was the one of the first parts out of probably over 100. The file sped up as soon as that part was deleted. 

Thanks everyone for your suggestions!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

LATEST

Glad you could solve it!

Thank you for the feedback.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 15, 2021 May 15, 2021

Copy link to clipboard

Copied

I would stay on Catalina OS until Big Sur gets an upgrade, but install additioanlly the free upgrade to Illustrator as this may flush out your issue, and you can keep both versions if you take your time and watch the settings in Adobe cloud.

 

Reset PrefsThoroughly (Mac)

  • Quit Illustrator (100% you must do this)
  • Finder >> Go (hold down option to show hidden) >> library 
  • Preferences >> Adobe  >> (Program Name) rename to (Program Name) .old
  • Library- >> Caches >> com.(Program Name) rename to (Program Name) .old
  • Library >> Application Support >> Adobe >> (Program Name) rename to (Program Name) .old

 

OOBE

  • Quit the Creative Cloud desktop app   (100% you must do this)
  • Browse to the following location based on your operating system.
  • MACOS
  • /Users/<user folder>/Library/Application Support/Adobe/OOBE
  • The \Users\<user folder>\Library\ is hidden by default for macOS 10.7 and above. See Access hidden user library files | Mac OS 10.7 and later for instructions to access it.
  • Delete all the files within the OOBE folder, but do not delete the folder itself.
  • Restart the computer and launch the Creative Cloud desktop app again.
  • Delete all the files within the OOBE folder, but do not delete the folder itself.
  • Restart the computer and launch the Creative Cloud desktop app again.

 

https://helpx.adobe.com/illustrator/kb/optimize-illustrator-performance-mac-os.html

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 17, 2021 May 17, 2021

Copy link to clipboard

Copied

Hey Mike,

Thanks for taking the time to reply.

I'll run through this and let you know if it resolves anything. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 15, 2021 May 15, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry about this trouble. I am hopeful that the issue is resolved by the suggestions shared above. If not, you may try the suggestions shared on this page ( https://community.adobe.com/t5/illustrator/resolve-slow-performance-and-unexpected-behaviors-in-illu... ) and share your observations with us.

 

Regards,

Srishti

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines