• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
6

Anyone else experiencing this strange masking issue in Lightroom Classic?

Community Beginner ,
Dec 14, 2023 Dec 14, 2023

Copy link to clipboard

Copied

About two months ago I had a peculiar and extremely irritating problem with masking in Lightroom Classic. It started without warning, and it lasted for weeks - and then it disappeared as suddenly as it had started, without my ever finding out what was going on. There followed several weeks when everything behaved as it should...and now it's back! I would love to know (a) whether anyone else has experienced the following, (b) what's going on, (c) HOW DO I FIX IT?!!!

 

One more thing: I tried uninstalling and reinstalling Lightroom the first time the problem. That didn't work.

 

The problem affects all masks. That is, whenever I create any mask: it can be an object; a brush; any kind of gradient; a person (including all elements, i.e. facial skin, body skin, hair, teeth, etc.).

 

Here's what happens: I click to open one of the above masks. The mask opens, however a string of changes have been made which seem to relate to edits I have made on photographs in earlier editing sessions: whites in the basic panel are lowered; the saturation has been turned to zero, so whatever is masked is black and white; in the tone curve, changes have been made in the red, green and blue channels. In other words, I am not starting with a 'clean slate', with everything reset to zero or neutral values, as should be the case. And, to be clear, I can turn off and restart Lightroom, I can even turn off the computer and re-boot, the same edits will still be 'pre-applied' to all masks.

 

To use a mask, therefore, I first have to hit reset in the Basic panel, and I have reset the channels in the tone curve. It's distracting, annoying and it interrupts editing, especially when I am applying several masks to a single photo.

 

Once I've put everything right, things work as normal, but as I say, I don't for the life of me know how this started.

 

Perhaps the problem will fix itself again, as happened a month ago, but I would really love to know what's going on.

 

Can anyone shed any light?

Cheers, and thanks!

TOPICS
macOS

Views

434

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Dec 14, 2023 Dec 14, 2023

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

Enable the option Reset Sliders Automatically:

 

johnrellis_0-1702623718067.png

 

Votes

Translate

Translate
LEGEND ,
Dec 14, 2023 Dec 14, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

Enable the option Reset Sliders Automatically:

 

johnrellis_0-1702623718067.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2023 Dec 16, 2023

Copy link to clipboard

Copied

Oops.

 

Heartfelt thanks, John! Where's that I'm-an-idiot emoji...?

 

Much appreciated!

Nick.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 16, 2023 Dec 16, 2023

Copy link to clipboard

Copied

Nothing to be ashamed of -- it's a recent change, and we all tend to be blind to such small changes in the UI.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2023 Dec 18, 2023

Copy link to clipboard

Copied

LATEST

Thank you, John - and that's interesting, I didn't realise that this was a recent innovation. If only you knew how much heavy sighing was happening during my edits!  Much calmer now...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines