• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

i have macOS Catalina. i need to Instal Lightroom Classic older version (v11)

New Here ,
May 12, 2024 May 12, 2024

Copy link to clipboard

Copied

I have older macbook whis mac OS Catalina 10.15.7 and i cant instal older version of Lr Classic from Creative Cloud

TOPICS
macOS

Views

62

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 12, 2024 May 12, 2024

Copy link to clipboard

Copied

LATEST

Contact Adobe directly (and type "Agent" into the chat field) and ask nicely for the link to LrC 11. Other people here have said this will work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines