• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Import - folder list in target panel opens slowly with files stored on a NAS

New Here ,
Dec 25, 2022 Dec 25, 2022

Copy link to clipboard

Copied

I have about 90.000 photos stored on a Synology NAS, connected to my Mac Powerbook Pro (2022) via Ethernet. My LrC Catalog (about 2 GB) is stored on the Mac. LrC is kept in the most updated version. Since a while now I'm having the following problem:

 

I have physically organized my photos on the NAS in folders by year with more subfolders inside each year's folders. When importing photos into Lightroom, trying to open the NAS folder list in the target pane on the righthand side takes ages. Simply clicking on one of the annual folders to unfold it and see the subfolders in it may take a couple of minutes with the wheel spinning. And frequently, after a couple of minutes the connection to the NAS is suddenly broken during this process. While LrC shows this behavior, I can easily and quickly browse through these folders in the Finder - until the conncetion if broken.

 

I thought, syncing the main folder on the NAS (which contains all annual folders as subfolders) could cure this. However, when trying to sync this folder, the connection to the NAS is also suddenly terminated during the process.

TOPICS
macOS

Views

98

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 26, 2022 Dec 26, 2022

Copy link to clipboard

Copied

Some thoughts:

 

- Make sure the Synology is configured to use SMB rather than the long-deprecated AFP.

 

- This person experienced connection problems, though perhaps not identical symptoms:

https://community.adobe.com/t5/lightroom-classic-discussions/lightroom-crashes-on-macos-ventura-macb...

 

See if his steps help you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 27, 2022 Dec 27, 2022

Copy link to clipboard

Copied

I switched off/on SMB file services on the Synology NAS as indicated in the link. Still the Sync Folder command in LrC does not work reliably. Interestingly, syncing folders with just a few hundred photos works, while trying to sync folders with a few thousand photos (mostly around 2,000 - 3,000), results in LrC terminating the connection to the Synology NAS. Maybe this behavior provides a hint that helps you to nail down the underlying problem, as there definitely seems to be an issue related to how LrC communicates with the Synology NAS, judging from the quoted link.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 28, 2022 Dec 28, 2022

Copy link to clipboard

Copied

LATEST

Have you talked to Synology support about this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines