Lightroom Not Defaulting to Latest Catalog

Community Beginner ,
Feb 25, 2022 Feb 25, 2022

Copy link to clipboard

Copied

have updated to LR v11 when it became available and updated my catalog. I'm now running v11.2.

 

Since upgrading to LR v11,  Lightroom always opens an old, non updated, verion of the catalog and gives me the option of using the orignal old verion or the newer, updated, version. On opening I would like Lightroom to always default to the most recent catalog.

 

I have tried changing my catalog preferences to "always use latest catalog" to no avail and have also tried specifying the specific verion of the catalog (ie the latest version), again to no avail. 

 

Can anyone please help.

 

thanks

John

TOPICS
Windows

Views

146

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Per, thanks for the tip.

 

I have just tried resetting preferences as you suggested. Unfortunately not effect. I'm still getting the "new catalog found" message with the option to select the newest catalog or an older version.

 

cheers

John

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Have you checked Preferences - General? You can define the catalog to use there. By default this is set to 'Most Recent', but you can also define a specific catalog. It sounds like that is what causes your problem. Select the appropriate catalog and see if that solves the problem.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2022 Feb 26, 2022

Copy link to clipboard

Copied

Thanks Johan.  Have tried that several times with no success even when I specify the catalog version to use. When I do specify the version it never seems to "stick" when I close & restart LR.

 

cheers

John

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 27, 2022 Feb 27, 2022

Copy link to clipboard

Copied

So just to make sure, are your preferences set up like this?

 

image_2022-02-27_095418.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 27, 2022 Feb 27, 2022

Copy link to clipboard

Copied

Hi Per.

 

Yep the screen shot is the same as my preferences. I'm still getting the option to to use the newest or another catalog.

 

cheers

John

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 27, 2022 Feb 27, 2022

Copy link to clipboard

Copied

You need to get rid of that "Load Most Recent Catalog" setting, use the dropdown arrow to the right and you should see a list of recent catalogs which should include the updated catalog ending in "-v11". Select that catalog, then restart LrC.

 

Alternatively, do as the tool-tip suggests and hold down the Ctrl key when launching LrC, that will give you the list of available catalogs to choose from. Select the "-v11" catalog, LrC will open with that catalog and then in future restarts that "Load Most Recent Catalog" setting WILL load the correct catalog.

 

Second alternative, use File Explorer to navigate to the "-v11" catalog on your hard drive, double-click to open it into LrC, then once again the "Load Most Recent Catlog" will in future open the correct catalog.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

Thanks Jim,

My latest catalog is ver 2-2-v11-5 (the -5 shows you how many times I'v
tried this style of solutio, it increments by 1 every time a new catalog is
created.

I have tried each of your suggestions with always the same result. Each
time I open LrC I get the "Upgraded Catalog Found" message with version
2-2-v11-5 being identified as the upgraded version. A very old ver-2-2 is
identified as the older version.

If I click on use the upgraded catalog LrC opens OK with the ver 5
catalog. But when I close and re-open I get the same "Upgraded Catalog
Found" message. LrC still does not default to the ver 5 catalog.

If, on the other hand I click on the "Ugrade The Older Catalog" then ver
2-2-v11-6 will be created. When I close & reopen ver 2-2-v11-6 I'll get
the "Upgraded Catalog Found" message with version 2-2-v11-6 being
identified as the upgraded version. And around we go again. The very old
ver-2-2 catalog is still identified as the older version.

In Preferences General "Use Latest Catalog" is specifed. Any changes I make
here do not stick when I close the tab.

In Catalog Settings the correct catalog (ver 2-2-v11-5) and catalog
location is identified.

I have to admit - I'm stumped!!

cheers
John

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

When you tried resetting the preferences, did you use the key combo or did you manually delete them? If you used the key combo, try if deleting the preferences file works.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

LATEST
I reset preferences with the key combo. I have just deleted my
preferences manually as you suggested and ...........it worked!!

Thanks so much Johan. I really appreciate the help. Thanks also to
everyone else for their suggestions

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 01, 2022 Mar 01, 2022

Copy link to clipboard

Copied

@jb64150744 

 

Have you tried this?

 

In the Preferences use the option "Prompt when starting Lightroom".

Restart.

When you restart in the window that will appear there's is an option, bottom left, that says "Always Load this catalog on startup" > Check that option > Select the catalog desired > Open.

 

.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines