• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Plugin not retained in Plugin Manager

Community Beginner ,
Apr 01, 2023 Apr 01, 2023

Copy link to clipboard

Copied

I'm using Lightrrom Classic 12.2.1 on Windows 10.

And I'm developinga plug-in in Lua.

Version 1 of my plug-in was OK.

But version2 of the plugin is NOT retained in the Plug-in Manager when I exit/resatrt LrC.

I have to 'add' it every time I start LrC.

While LrC is active the plug-in is available in Plugin Manager and I can run and debug it OK.

 

But next time I start LrC its NOT there. I have re-created the prefs file but that made no difference.

Anybody any clues what to look for to solve this strange effect?

 

Best wishes

Terry

 

TOPICS
SDK , Windows

Views

96

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Apr 01, 2023 Apr 01, 2023

Investigated further. The folder containing the plugin was tagged to syncrhonise with a Nextcloud server.

Removing that proprty fixed the issue.

Thanks for the pointers. I'm sorted now.

On to the next bug or is it a feature?

 

Best wishes

Terry

Votes

Translate

Translate
LEGEND ,
Apr 01, 2023 Apr 01, 2023

Copy link to clipboard

Copied

Is the plugin on an external drive or network volume?  When LR first starts, it checks for the existence of each plugin folder, and if it doesn't exist, it removes the plugin from the installed list of plugins.  Sometimes the operating system (Mac and Windows) will report to LR that a file doesn't exist if, for example, the external drive or network drive has been sleeping and is just starting to spin up.  

 

So put the plugin folder on a local disk.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 01, 2023 Apr 01, 2023

Copy link to clipboard

Copied

The plugin is on the same drive as other plugins that load OK.

But I'll investigate permissions on the folder just in case.

 

Thanks 

Best wishes 

Terry 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 01, 2023 Apr 01, 2023

Copy link to clipboard

Copied

Investigated further. The folder containing the plugin was tagged to syncrhonise with a Nextcloud server.

Removing that proprty fixed the issue.

Thanks for the pointers. I'm sorted now.

On to the next bug or is it a feature?

 

Best wishes

Terry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 01, 2023 Apr 01, 2023

Copy link to clipboard

Copied

LATEST

In general, LR doesn't play well with the cloud-sync services. They try to be totally transparent to apps but they're often not.  Most likely at some point LR queried the plugin folder and was (fleetingly) told by the operating system that it didn't exist.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines