Troubles to install Lightroom 4 updates

New Here ,
Jul 21, 2017 Jul 21, 2017

Copy link to clipboard

Copied

I receive an advice every time I launch my Lightroom 4 version. It says that is available an update to recognize some new camera model.
I agree and made click on the update button but it bring me to an Adobe page with free trial software, then, in a menu bar above, I click on "Software update" but I get a page with a list of Lightroom versions older than mine. This is useless to me, so I've read another string that says:
NOTE: Additional Lightroom downloads can be found here
I go there but I find a page that ask you installation code to reinstall completely your Lightroom software, if you haven't your media anymore.
In other words, no path of my Lightroom 4 update.
Could someone help me?
Thank you

Francesco

Views

2.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Jul 27, 2017 Jul 27, 2017

You can download Lightroom 4.4.1, which was the final update for Lightroom 4, here:

http://download.adobe.com/pub/adobe/lightroom/win/4.x/Lightroom_4_LS11_win_4_4_1.exe

Likes

Translate

Translate
Adobe Community Professional ,
Jul 21, 2017 Jul 21, 2017

Copy link to clipboard

Copied

The last update for Lightroom 4 was Lightroom 4.4.1, and that was several years ago. Lightroom 4 is no longer being supported or updated by Adobe. What is the exact version of Lightroom 4 installed on your computer?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2017 Jul 27, 2017

Copy link to clipboard

Copied

Hi Jim,

when I open Lightroom I receive this advice:

Lightroom update.PNG

so I think my version is the 4.1, and the advice says me to install 4.4, but I can't...

I don't expect an update to 2017, I would like just a 2014 update, because the software doesn't recognize a Lumix camera I use, that was produced that year.

Thank you and best regards

Francesco

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jul 27, 2017 Jul 27, 2017

Copy link to clipboard

Copied

You can download Lightroom 4.4.1, which was the final update for Lightroom 4, here:

http://download.adobe.com/pub/adobe/lightroom/win/4.x/Lightroom_4_LS11_win_4_4_1.exe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2017 Aug 05, 2017

Copy link to clipboard

Copied

Thank you very much, Jeffrey, this link works fine and I've installed the update.
So I can open raw files from my EOS 6D.
Best regards

Francesco

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2017 Aug 13, 2017

Copy link to clipboard

Copied

I have a same problem but on mac. I could't find any update packages for lightroom 4. There was only updates for 1.1 to 3.6. I have a Fuji xt2 is it worth of money to buy a lightroom 6? By the way I prefer using stand alone versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 16, 2017 Aug 16, 2017

Copy link to clipboard

Copied

See this post for where to download LR 4 for Mac: Re: Looking for Lightroom 4 Mac installer download

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 19, 2021 Dec 19, 2021

Copy link to clipboard

Copied

That link doesn't work for me Jeffrey. I know it's been a few years since you posted it but got an updated link per chance?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 19, 2021 Dec 19, 2021

Copy link to clipboard

Copied

There is a related thread just above this one that has the link.

https://prodesigntools.com/adobe-lightroom-4-is-out.html

 

 

 

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.8,; LrC 11.4.1, Lr 5.4.1, Ps 23.3.2-ACR 14.4,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 19, 2021 Dec 19, 2021

Copy link to clipboard

Copied

LATEST

Prodesigntools.com has a valid link for Windows LR 4.4.1, but the one for Mac doesn't work. See here for links to both Windows and Mac versions:

https://community.adobe.com/t5/lightroom-classic-discussions/update-lightroom-4-1-to-4-4/m-p/1253914... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

Hi Jeffery

 

I have Lightroom 4.3.64 from back when I anticipated doing a lot of digital work.   It didn't happen and only started to use it when I got a Canon 6D mark ii.  But it cannot read my CR2 raw files but I understand Lightroom 4.4 can.  Unfortunately I missed the update window and now Lightroom 4 is unsupported and the 4.4 upgrade is no longer available. 

 

Is there anyway I can get the upgarde to 4.4?    Help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

"Is there anyway I can get the upgarde to 4.4?"

 

Yes, someone has posted a working link recently (last month or so), so you need to search this forum.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

Your info is incorrect.  The canon 6dmk2 requires at least 6.12

 

Screen Shot 2020-05-03 at 8.36.00 AM.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2020 May 03, 2020

Copy link to clipboard

Copied

Getting updates for such ancient versions of Lightroom are becoming more and more difficult to obtain. Adobe isn't making them readily available. Adobe doesn't support that version anymore. Anyone who is really serious about using Lightroom has upgraded. Otherwise, they have moved to other software. It will probably even be difficult to get support on this forum for software that old.

 

If that is your camera model then you will either have to convert your raw files to DNG using the free DNG converter from Adobe, or change to some other raw converting software. There is no version of Lightroom 4 that will do the job for you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines