LrC & Photoshop 2021 import export issues

New Here ,
May 08, 2021 May 08, 2021

Copy link to clipboard

Copied

Hi there, as part of my work flow I've always used *command E* as a shortcut to export an image from LrC to Ps in order to do fine touch up and more detailed editing on select photos. However I'm getting error messages. This has never been an issue before the recent update.

 

One error message I recieve is: "The file could not be edited because Adobe Photoshop 2021 could not be launched."

 

However, Ps is open and operational, moments later I'll see the image pop up in photoshop, then I'll do the edits, and use the same shortcut (command E) to export the edited image back into LrC. However the edits are not applied to the new copy of the image which appears as a copy, beside the original.

 

The other error message I'm recieving is: "An internal error has occured. AgStoreProviderSession:getEntityByID: id must be a number or string." 

 

I'm not sure what's going wrong. I've tried to close everything down and re-open everything multiple times... 

 

Please advise!

Views

302

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2021 May 08, 2021

Copy link to clipboard

Copied

[Moderator moved from Using the Community (forums) to Lightroom Classic.]

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2021 May 08, 2021

Copy link to clipboard

Copied

LATEST

When you edit in Photoshop, you do not do Cmd-E to send the file back to Lightroom. You just close the image and save when you're prompted. When you use Cmd-E in LRC, the first thing that happens is that LRC renders a copy as PSD (or TIFF depending your settings) and sends the copy to PS. When you close and save, that PSD copy is automatically added to your Lightroom catalog. If you don't save, it's not added. 

If you export a copy from PS, it is not added to LRC. LRC has no way of knowing you created yet another copy. 

All this doesn't address the error messages you're getting, though. Id try resetting the preferences to default to see if that helps, before possibly uninstalling and reinstalling. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines