Maps/Places feature not working in Elements Organiser 2020

New Here ,
Mar 10, 2022 Mar 10, 2022

Copy link to clipboard

Copied

I have Elements 2020 and haven't used it for quite a while.  I notice that the Maps/Place feature no longer works, I've tried searcing for a solution online without success.

When I click on the Places tab I get a 404 error page which seems to suggest that the application is not connecting correctly, see screenshot.

Can anybody point me in the right direction?  I'm using Mac OS Monterey.

Places screenshot 10 03 20jpg.jpg

 

TOPICS
Bug , Mac , Organizer , Problem or error

Views

71

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Advisor , Mar 14, 2022 Mar 14, 2022
Monterey? easy:  You gotta purchase the latest version of PSE. Any other questions?  Seriously though: that's your only option.  Interesting Organizer would even start. 

Likes

Translate

Translate
Advisor ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

LATEST

Monterey? easy:  You gotta purchase the latest version of PSE. Any other questions?  Seriously though: that's your only option.  Interesting Organizer would even start. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines