PSE '19 on Mojave Has Spinning Wheel on EVERY Action

Community Beginner ,
Oct 14, 2018 Oct 14, 2018

Copy link to clipboard

Copied

Installed Photoshop Elements 2019 on Mac OS Mojave and now every action in Photoshop Elements 2019 Editor has a several second delay with the spinning color wheel. I see lots of similar complains on this forum. Has anyone received any help from Adobe to investigate or fix this problem? Anyone have any solutions?

TOPICS
Problem or error

Views

16.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 29, 2018 Oct 29, 2018

Hi jameslarus,

Thanks for posting in Adobe forums.

It seems you are facing issue with spinning wheel in Adobe Photoshop Elements after upgrading Mac OS.

Could you please try the following steps :

• Click Apple icon >> System Preferences

Security and privacy >> Click on the lock to unlock it then enter the administrator password >> Enable (check the radio button) the Photoshop Elements 2019 editor and Elements Organizer 2019 that appear in the list.

• Click on the lock again to lock it.

• Restart Mac

H

...

Likes

Translate

Translate
replies 107 Replies 107
Explorer ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

I've unchecked the boxes, but how do I verify that the ElementsAutoAnalyzer is not running in the Activity Manager? I have an iMac if that makes any difference.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 30, 2019 Mar 30, 2019

Copy link to clipboard

Copied

Hi

If it’s on it usually displays in bottom right

hand corner it is doing it with progress monitor

I am away from my pc currently but I think

you select Preferences and I think the switch

is under the general section. Or go to Help

Hope that is ok

Sent from my iPhone

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 19, 2019 Mar 19, 2019

Copy link to clipboard

Copied

done all those suggestions

Adobe is hiding. Ive had there tech guy control my Mac change all kinds of settings and its still useless. coloured beachball all the time.

They know they have a problem and its been weeks and no update. what ever you do tell people not to but any adobe software if this is how they treat us.  I dont normally complain but I use this for work every day and the frustration is massive.

I've done all the sugessted changes you see around and nothing works for very long.

Adobe why haven't you said anything?????

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 19, 2019 Mar 19, 2019

Copy link to clipboard

Copied

Well, I updated to version 17 as advised and, so far, so good. Haven’t done any heavy work yet, but clone tool seems to be working correctly.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 20, 2019 Mar 20, 2019

Copy link to clipboard

Copied

I agree - NOTHING is working. Tired of having to jump through all these hoops. Adobe needs to resolve this. We need to start flooding social media with this information and warn everyone to NOT waste their money on PSE. I was told I had to update to PS 19 in order to resolve this. So, I did, and it got worse. This is ridiculous. It shouldn't take 30 minutes and opening and closing this, that and the other for a simple 30 second process.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 20, 2019 Mar 20, 2019

Copy link to clipboard

Copied

I just installed the update released yesterday.   It appears to have resolved the problem for me.   I have been dealing with the issue for over 2 years .. had to close organizer in order to use the editor.   After editing 8 photo's with the update .. I am not having the problem .....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2019 May 15, 2019

Copy link to clipboard

Copied

The number to call in Australia for Adobe 1800614863 I called and someone worked through various steps with me, it works better, still not perfect though

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 25, 2019 Jul 25, 2019

Copy link to clipboard

Copied

LATEST

So I am wondering if my Elements Organizer Catalog is too large with 150,000 photos from nearly 20 years.  So I tried creating a new catalog, and there is no spinning wheel.  But still I have the problem with the old catalog. 

Is there a way to move, or copy, a bunch of photos (like a years worth) from the old catalog to the new one?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines