• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Index display is strange after upgrading xpj to rhjp.

New Here ,
Jun 16, 2021 Jun 16, 2021

Copy link to clipboard

Copied

I updated xpj to rhpj. In the old xpj, Index was created without any problem, but in updated rhpj, most Indexes are displayed as having no link.

The RH currently in use is 2020.

Fig1.pngIt's a hassle to fix thousands of pages by hand, so if you know an easy relinking method, please let me know.

Views

128

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 16, 2021 Jun 16, 2021

Copy link to clipboard

Copied

Hmm, that's the table of contents, and the red crosses generally indicate the files don't exist in the project. Do your topics show correctly in the Contents panel?

 

If you have a backup of your project I'd recommend making sure you have all the patches installed and try upgrading again.

 

Check you have the latest patch using Help > About Robohelp.

If Help > About Robohelp shows 2020.0, then you will need to download the latest patch manually, as there was a bug which prevented the updater working in that version. 

https://www.adobe.com/support/robohelp/downloads.html

 

If that doesn't help and you still have Robohelp Classic if might be worth checking some things there before trying to upgrade.  If you need to try this, let us know, and include what version of Classic you are upgrading from.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Dear Amber-san,

 

Thanks for your prompt reply. I'd like to referrer your comment.

Do your topics show correctly in the Contents panel?

--->No. Most of them are missing. I dont know why that wrong has been caused.

--->I already use 2020.5.71. (It shows in help-> About RoboHelp) So, I suppose I use the latest version.

---> The version of Classic that I used until last year is RoboHelp 10.0.1.292.

 

Please let me know if there is any way to check.

It is quite inconvenient if that updated rhjp cannot be used as it is (or with some editing).

 

Regards,

 

T.Kitagawa 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

How did you upgrade from your previous version? You said I updated xpj to rhpj rather than you upgraded. Did you open 2020 and use the Upgrade Project link?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

You said you used RH10 until last year. Does that mean you have been working on the project using RH2020 all year, and the table of contents just broke? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Amber-san,

 

Thanks a lot.

I will explain it in chronological order.

Until last year, I used RH10 on an old PC (Call it PC-A).

In RH10 it was possible to create with *.prj.

(For example, let's call this RH_10.xpj)

But This year, the PC-A was also aging, so I have to have new PC-B.

And I thought about upgrading to RH2020 there.

However, I tried to upgrade RH_10.xpj to rhpj on RH2020, but it didn't work.

That's my secnario.

Please tell me if there is a lack of explanation.

 

Regards,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

It's very late where Amber is.

 

You have repeated I tried to upgrade RH_10.xpj to rhpj on RH2020, but it didn't work.

 

What you haven't answered is how as I asked earlier. You needed to copy the whole project from you old machine to your new machine, then open 2020 and use the Upgrade Project link. Is that what you did?

________________________________________________________
See www.grainge.org for free Authoring and RoboHelp Information

Help others by clicking Correct Answer or Like if helpful. Found your answer elsewhere? Share it here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Let me quote a part.

What you haven't answered is how as I asked earlier.
--->I'm very sorry. It seemed not to I don't answer what you want.

You needed to copy the whole project from you old machine to your new machine, then open 2020 and use the Upgrade Project link.
Is that what you did?
--->Yes. I did. I copied whole project folder from old machine(RH10 installed) to new machine (RH2020 installed). But it didn't work

Regards,

T. Kitagawa 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

LATEST

Another person has a problem upgrading from RH9. 

 

Vivek has commented they need to upgrade to RH2019 Classic first, then upgrade 2019 Classic to RH2020:

https://community.adobe.com/t5/robohelp/project-upgraded-from-rh9-to-rh2020-missing-all-topics/td-p/...

 

You can download  2019 Update 14 from here:

https://www.adobe.com/support/robohelp/downloads.html

 

The installation includes 2 versions of Robohelp 2019, so make sure you open "Adobe Robohelp Classic 2019".

 

Also, as always, make sure you have a zip file backup of your project, just in case something goes wrong.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
RoboHelp Documentation
Download Adobe RoboHelp