• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

UI Scaling on 4k monitor

New Here ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

On my 4k monitor, the UI looks too small. Is this issue still unresolved?

TOPICS
Bugs & Crashes , Discussion

Views

342

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 06, 2022 Oct 06, 2022

Hi

With the last release of Painter 8.2.0, we should have fixed most UI scaling issues related to multiple monitors and HDPI monitors.
change log: 
[UI] Resolve scaling issues for high-DPI screens: Improved Painter UI adaptation on high definition screens with custom display scaling.

more info on: https://community.adobe.com/t5/substance-3d-painter-discussions/painter-8-2-0-is-now-live/td-p/13249065



Likes

Translate

Translate
New Here ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

Same here. The scaling on a 32 inches 4k monitor is horrible. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

Been suffering with this for a long time.
I think it's realted the UI implementation (software used to build the UI) and as I understood it from previous dives into this issue, it can't solved easily.  I dearly wish it was, as big 4k monitors is your go-to-solution for art production these days. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2022 May 19, 2022

Copy link to clipboard

Copied

The same related issue here but in my case, the UI is too big.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 06, 2022 Oct 06, 2022

Copy link to clipboard

Copied

Hi

With the last release of Painter 8.2.0, we should have fixed most UI scaling issues related to multiple monitors and HDPI monitors.
change log: 
[UI] Resolve scaling issues for high-DPI screens: Improved Painter UI adaptation on high definition screens with custom display scaling.

more info on: https://community.adobe.com/t5/substance-3d-painter-discussions/painter-8-2-0-is-now-live/td-p/13249...



Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2022 Oct 25, 2022

Copy link to clipboard

Copied

I cannot find a solution on the link you've shared 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2022 Oct 25, 2022

Copy link to clipboard

Copied

I literally cannot read the characters, they're too small, can we please have some guidelines on how to change the UI setting?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2022 Oct 25, 2022

Copy link to clipboard

Copied

Hi,

Painter used to not take into account your scaling values, defined in the Windows settings.
Now we do take this value into account, which can change the scaling of Painter, and it will look bigger or smaller than before, but it is the "correct" scaling according to the Windows Settings we used to ignore.
This used to lead to numerous issues on a lot of configurations.However, it should be possible for you to simply deactivate the scaling on Painter, through some windows settings.
Change application properties : Right-click the application .exe, select Properties, select the Compatibility tab > "change high DPI settings",and then select the Override high DPI scaling behavior check box.
You can find more infos here : https://support.microsoft.com/en-us/topic/windows-scaling-issues-for-high-dpi-devices-508483cd-7c59-...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Hi, thanks for getting back to me,

I did that but nothing changed, it is still extremely small (I am using 4k monitors).

Please let me know if there is any other way.

Thanks and regards,

D

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 07, 2022 Nov 07, 2022

Copy link to clipboard

Copied

LATEST

Hi, Unfortunately, there is no other solution. If you do not ignore the window scaling, the only other way to make Painter bigger is to up your scaling within Window's settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources