The official community for ColdFusion.
Recently active
Hi,We are running ColdFusion 9.02 with all the hotfixes and updates and as of late I'm starting to get more "Internal Server Error 500" instead of the standard ColdFusion Errors. It seems to happen in CF 10 too.It seems like these errors come from the web server (IIS in this case), but it makes it difficult to troubleshoot the problem. I feel like something changed because I'm seeing more of these rather than getting the typical CF error when something goes wrong. When I see error 500 I feel like it is more of a web server error, but maybe I'm wrong.I use Firefox a lot and have the Firebug plugin and at times I see the actual ColdFusion error message listed in Firebug, but in my browser window I see "Error 500 internal server error.Does anyone know why I might be getting general Error 500 issues versus seeing the standard CF error messages when something goes wrong?Any help appreciated.
Trying to define ODBC datasource for Excel. Getting foloowing error:Connection verification failed for data source: ABCDEFjava.sql.SQLException: [Macromedia][SequeLink JDBC Driver]TCP/IP error, connection refused.The root cause was that: java.sql.SQLException: [Macromedia][SequeLink JDBC Driver]TCP/IP error, connection refused.Also, getting same errot for a Microsoft Access datasource.Any suggestions? Thanks in advance.
We have some sites in production that were working fine before we went from CF8 to CF10. We upgraded to CF10 yesterday and our data analysts couldn't update the site with HTML files. We were getting a 500 server error without any information to go on. Don't you hate that? We do. At least give me a CF errror I can chase down. Anyway, the first issue was on 3 seperate webpages, Coldfusion 10 not interpreting HTML files when uploaded through a form. The Mime type that was used a day earlier and for the previous 5 years the site has been live is: text/html. It's always worked perfectly. It turns out, when you upgrade to CF10 and you use CFFILE or regular INPUT TYPE="File" with the ACCEPT attribute, you must inlude: application/xhtml+xml to be able to upload an HTML file now. One word: STUPID! Now here is current issue. In 4 separate webpages, our data analysts cannot update the site with ZIP files. Coldfusion 10 is not interpreting ZIP files. we assume it was a MIME typ
i am using the following code to open a file on a cfm page ie.,when user clicking on a hyperlink it opens the cfm page and displays the pop up to save the file <cfif isdefined("url.isemailPopUP") and trim(url.isemailPopUP) eq "Y"> <cfif isdefined("url.fileName")> <cfif #find(url.fileName,#fileWithThePath#,1)#> <cfheader name="Content-Disposition" value="attachment; filename=#url.fileName#"> <cfcontent type="text/plain" file="#fileWithThePath#"> </cfif> </cfif> </cfif>but after the file has been downloaded .it does not displays the contents of the page or redirects to the same page ....i have used cflocation. but it does not help....
Recently I use cfthread writing a multithread samples. Each thread ask a http request.When I run this cfc file with coldfusion9 on windows, it runs well. Then I run the same cfc file on coldfusion9 on linux(RedHat and centOS), unfortunately, it seems do not work, I found the multi thread do not run parallely, they run one by one. The both coldfusion configuration files are same, and the web server use the built-in one of coldfusion. Is there anyone meet the same probelm? And is there something wrong with cfthread to run on linux? Really need your help. Many thanks!
I am receving contents in japnese language from server , and i am unable to display unicode characters.cfm code:<cfhttp method="post" url=" http://localhost/sampleWeb/readLetter.do" resolveurl="Yes" charset = "utf-8"> <cfhttpparam type="header" name="accept-encoding" value="deflate;q=0"> <cfhttpparam name="docID" type="FormField" value="595"></cfhttp> <cfset source="#cfhttp.fileContent#"> <cfprocessingdirective suppressWhiteSpace = "yes" pageEncoding = "utf-8"><cfoutput> #html_src#</cfoutput> </cfprocessingdirective>&n
hi allhow can i get of number of total pages in a cfreport?i try with a custom field with count on calc.PAGE_NUMBERbut i obtain this error: Error: calc.PAGE_NUMBER is not a valid ColdFusion expression.any idea?many thanks
Hi,I have a link on another page the take me over to the page that contains the code below:<CFOUTPUT><CFSET FPATH = #GetDirectoryFromPath(ExpandPath("*.*"))#><cfdirectory directory="#FPATH#" name="FILES" action="LIST"><TABLE><CFLOOP Query="FILES"> <TR><TD><CFIF #FILES.NAME# EQ "test.cfm"> <A href="#FILES.NAME#"> #FILES.NAME# <cfheader name="Content-Disposition" value="attachment;filename=#FILES.NAME#"></A></CFIF></TD></TR></CFLOOP> </TABLE></CFOUTPUT>When I select the test.cfm link, a dialog box appears asking to either Save or Open the file.The issue is the file, test.cfm, contents is not what is being saved or displayed when Open is selected.Is there something I'm missing?Thanks,Mike
I have two requests that I am not sure can be done with CF's spreadsheet functions. The first is to insert cr/lf after multiple values in a cell. It is done in Excel with alt-enter. The other is adding AutoFilter to the header row.Are either of these possible?Thanks
Can someone please give me a definative answer if there is a work around for this bug. I am creating a new web app on CF8 and IIS 7 in which I would like to utilize IIS for SEO friendly URLS - Inbound and Outbound.I know there are other ways of doing this w/ frameworks, ISAPI etc... I am not looking to do that. I have inbound rewrite rules working great. As soon as the outbound rules are enabled in IIS, all requests that go through the CF Server get killed w/ connection reset. HTML pages will work fine - just anything processed through the CF server is killed. I have tried many suggestions like:make sure static or dynamic copression is disabled...try disabling and re-enabling compression... set outboundRules rewriteBeforeCache="false"... None of these have worked so far. I even tried the old hack of adding .htm into the web.xml file for CF server to process - didn't work as anticipated.  
Just installed Developer edition of CF10. On a new Windows 2008 server. Registrar pointing to correct server; everything working OK. Sort of. When I type in to my browser at the office (no where near Data Center), the domain resolves fine and I get the home.cfm page display just as it should. CF is picking up from IIS the default document home.cfm. The menu and other hyperlinks appear and when I click on them I get a 404. All the files are there. When I type in the URL www10.mydomain.com the home page comes up. When I type in www10.mydomain.com/home.cfm it fails. Which tells me that IIS is correctly going to the right path and displaying the right file. In the debugging screen I see where a whole bunch of other files have been included. Also when I enable directory browsing in IIS I do not get a listing screen ... be nice to see where IIS thinks it is. Why would the inclusion of the actual template send IIS into a tizzy? I res
I'd like to do the following in CF.I understand the CF vars will be resolved on the server side and clients won't see the CF, but just making sure.I want to do this in my CF pages.<title>#title_info#</title><meta name="keywords" content="#keyword_info#">Then I can update #keyword_info# and #title# elsewhere.(Maybe this is also good for a Google site question, but SEO won't be affected, right?)Thanks for any suggestions/advice.Cheers.
Our plattform is:Coldfusion 9.01Windows 2003IIS 6We did not upload any code or did anything on the server. Our site was unresponsive and we restarted the server. After that we are getting following when hitting the pages that try to accdess cookies, also I can't access coldfusion admin that was running on coldfusion built in server.: Any ideas?05/01 17:24:07 error ROOT CAUSE: java.lang.IllegalAccessError: tried to access method coldfusion.runtime.NeoPageContext.isUnderCFThread()Z from class coldfusion.runtime.CookieScope at coldfusion.runtime.CookieScope.bindName(CookieScope.java:90) at coldfusion.runtime.CookieScope.bindAsScaler(CookieScope.java:81) at coldfusion.runtime.NeoPageContext.SymTab_setSplitNameInMap(NeoPageContext.java:1389) at coldfusion.runtime.Neo
We recently applied the APSB13-10 update to CF9 and have run into issues with applications. With the setting defaulted only to 100, compared to tomcat's 10,000 max post param default, I am wondering what the reason behind the 100 default is and what is considered the max safe value for this setting. There are no specific details in the CVEs or the APSB-13-10 bulletin that seem to indicate what this is for. Also the details in the adobe bulletin versus the CVEs seem to contradict each other murkying exactly what the vulnerabilities are that are being patched. The descrepency I am refering to is in the adobe bulletin you state "This hotfix resolves an information leak that can occur in certain multi-threaded use cases. This issue is not exploitable remotely (CVE-2013-1387)." However when looking at that particular CVE it says "Unspecified vulnerability in Adobe ColdFusion 9.0 before Update 10, 9.0.1 before Update 9, 9.0.2 before Update 4, and 10 before Updat
Hello,I am running a local CF10 dev server and and full version on my test server. Both have all of the latest updates. I moved a template from my local instance to my test server and CFFLUSH does not output at the set interval. Is there a setting in the administrator that much be put in place for this to work properly?
Currently have a client with SQL 2008 and ColdFusion 9. They are upgrading to SQL 2012. Do they need to upgrade CF to 10? Or will 9 work?
Is it possible to upgrade from 7 to 9 instead of having to purchase 10? I was not able to find a way to purchase 9 on the Adobe website.
This question was posted in response to the following article: http://help.adobe.com/en_US/ColdFusion/10.0/Developing/WSc3ff6d0ea77859461172e0811cbec0c35c-7fd5.html
There are some organizations like DISA/DOD that require when using IIS 7/7.5/8 that you set the Request Filtering -> File Name Extensions -> Edit Features Settings -> Allow unlisted file name extensions to be disabled. This then forces you to add every single file extension type needed as an Allow entry in the File Names Extensions section for them to run. I wanted to make this post because it's easy to miss one of the items required which will then result in the system not functioning as expected. There are several obvious ones as without them allowed the CFIDE will not load at all. However if you miss the .js item you run into issues. The system will continuously inform you that your password is invalid when it really is not. Unlike all of the others the lack of .js will not show itself visually except that all menu items are pre-colapsed and you can't login via username/password making you have to bypass security.Here is the list of items
Hi everyone,I have a problem while using the function deserializeJSON.I have a request looking like this :Request: { 'config': { 'bgSubtractor': { 'config': { 'learningRate': 1e-06, 'mogHistory': 52, 'mogSigmaSquared': 80.456140350877}, &n
When I download and unzip the "mandatory" patch for CF10, the jar file is not in the directory. therefore, I cannot install this patch or any subsequent patches.
I just installed CF10 on a Windows 2008 R2 server. The last step in the installation processs is to log into the CF administrator. When I try this in the browser on the server, my password will not be accepted. It works fine if I use the browser on my workstation. How can I get the browser on the server to accept my password?
I just installed CF10 on a RHEL 5.7 system and cannot render the administrator login. I get a error 503, service unavailable message. Digging deeper I see that the apache connector is failing to connect to port 8012 and the error suggests that either Tomcat is not running or the port definition is incorrectly defined. I don't think either one of these are the case. I notice a number of connector issues with the original release of CF10. First, is there any solution for this? Also, does the current download of CF10 include any hotfixes?
Specifically for hotfix APSB13-10 for ColdFusion 9.0.1, is there a way to verify the hotfix installation other than checking for the updated hf901-00009.jar file or other updated files? Is there a version change that can be seen in ColdFusion?
Hi, I have 2 ColdFusion instances (different machines) in a cluster on amazon EC2.They are working fine, except for session replication.EC2 don't support IP multicasting. So, I am trying a static approach.I had added a static member interceptor:<Interceptor className="org.apache.catalina.tribes.group.interceptors.StaticMembershipInterceptor"> <Member &nbs
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.