Questions
Recently active
I'm trying to move a table from a MS Access database to a datasource online so I don't have to be the only one that can perform a specific task.Right now I regularly am having to assess change requests to determine if it impacts the servers my team supports. Currently I copy and paste the text list into a temporary table in MS Access then hit a button to run a query comparing what was in that list to my server inventory. Works fine but now I need to move this online so others can do this in a place where we can also keep everyone using the exact same inventory and am planning on using a ColdFusion server.So what I believe would be easiest is to create a form that has a textarea where I can just copy and paste what is in the change request and then hit a submit button and go to the next page where it would list all the servers that matched (with all the other info I also need).Almost always the info would hit the textarea with a separate row for each server with no other del
I just submitted this to the bugbase. Has anymore else run into this issue after installing Microsoft KB3032359?Problem Description: After installing Microsoft KB3032359, if you copy an image from one domain and paste it into the TextArea on a webpage on a different domain, the Image Properties for the image is changed to http://bbb.abc.com/CFIDE/scripts/ajax/FCKeditor/editor/images/testimage.jpgSteps to Reproduce: Copy image from http://aaa.abc.com/images/testimage.jpg and paste it into a TextArea field on http://bbb.abc.com. Actual Result: The Image Properties for the image will automatically change to http://bbb.abc.com/CFIDE/scripts/ajax/FCKeditor/editor/images/testimage.jpg Expected Result: The Image Properties should remain as http://aaa.abc.com/images/testimage.jpg Any Workarounds: Don't install KB3032359. Use Chrome instead of IE11. Copy/paste correct URL into Image Properties
Hi,I need to generate a chart with two Y axes.Is there an easy way to do that in CF11?Thanks and best regardsClaudia
Is it possible that when using cfexchangecontact to create a contact on the Exchange server, also specify a file as the photo of that contact? I can manage to create all the other text fields but cannot find any reference as to how to create/update the photo. I am using CF10 but if CF11 has this function I'll be happy to learn about it too.
This is a fresh install (server) onto W2K8 with IIS 7.5 per the Adobe ColdFusion 10 Lockdown Guide. My CF Admin section works fine. I created a new site and created an index.cfm file (which is the only default document in IIS). If I browse to www.domain.com it loads the index.cfm file just fine. But, if I go to www.domain.com/index.cfm I get a 404. If I create a .htm page and navigate to it - www.domain.com/somepage.htm - it works fine.I've checked the request filtering vs. the cf admin site in IIS and both are the same (except for CFIDE/Admin in the admin site). My mapping to the cfform scripts works fine in my new site (www.domain.com/cf_scripts/cfform.js). CFCs called from my index.cfm page work fine (as long as I load it with just www.domain.com and not www.domain.com/index.cfm).
Server: Windows 2008, CF 9. Standalone server.I found this reference:"ESAPI.properties could not be loaded by any means. fail." causing "Could not initialize class coldfusion.security.ESAPI…That points to this solution.Add a file read permission to the esapi.properties file present in <CF_HOME>\lib directory for each sandbox. If you can not access CF Admin console manually add this permission in neo-security.xml which can be found in <CF_HOME>\lib directory.Question: Since Im not running it on a sandbox, who do you apply the read permission to on the xml file?
Hello, everyone,I'm running this project under CF10 (Windows7 Pro), and I'm getting a weird session issue in regards to Internet Explorer 10.I have a page with a form that is using CFIMAGE for its CAPTCHA ability. Before the form page loads, I have CF code that is creating a string of random numbers/letters/characters (I found out to NOT allow '#' as one of the characters) to use in the CAPTCHA image. This is also being hashed and saved to a session variable so that upon submit the CFC can hash() the user input and compare the values.<cfscript> stringLengthCap = 6; stringListCap = "2,3,4,5,6,7,8,9,a,b,d,e,f,g,h,j,n,q,r,t,y,A,B,C,D,E,F,G,H,K,L,M,N,P,Q,R,S,T,U,V,W,X,Y,Z,@,%,&,?"; stringNameCap = "a,b,c,d,e,f,g,h,i,j,k,l,m,n,o,p,q,r,s,t,u,v,w,x,y,z,A,B,C,D,E,F,G,H,K,L,M,N,P,Q,R,S,T,U,V,W,X,Y,Z"; rndStrCap = ""; rndInptCap = ""; rndClassCap = ""; &nbs
I have two CF10 instances on a server. After applying hotfix 15 the second instance will not start. There are 4 sites, 3 in one instance and the fourth in another. I configured 3 connectors via the wsconfig tool in cfusion and the fourth via wsconfig tool from the second instance.A command line start shows this error...any ideas?SEVERE: Failed to initialize connector [Connector[AJP/1.3-8013]]org.apache.catalina.LifecycleException: Failed to initialize component [Connector[AJP/1.3-8013]] at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106) at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559) at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102) at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:813)  
Has anyone experience with MongoDB and Coldfusion?I have problems to store a Date object correctly in MongoDB.I am using the Mongo-Java Driver.
Hello,Just after confirmation on how CF11 Enterprise licenses apply to AWS. From reading the terms, one Enterprise license would be required for an instance of up to 8 vCPUs.Is it possible to apply an Enterprise license to multiple instances, for example two 4 vCPU instances to make up the 8 vCPU allowance?I'm aware of the CF11 options available in the AWS Marketplace, just trying to evaluate the best option.Thanks,Chris
Hello,Has anyone else tried to use CF with Java 8 preview? If you have tried Java 8 preview have you noticed anything interesting?Something to share. Java 8 uses memory differently to Java 7 or 6 (reminder Java 6 is EOL). The non heap memory Permanent generation has been done away with and is now consumed in a new memory space called Metaspace. I guess that will mean CF folks will not see the dreaded “java.lang.OutOfMemoryError: PermGen space” in coldfusion-out.log anymore.For interested readers here is my CF10 Summary part:Server Settings > Settings Summary System Information Server Product ColdFusion Version ColdFusion 10,284825 Operating System Windows 7 OS Version 6.1 Update Level /C:/ColdFusion10/cfusion/lib/updates/chf10000010.jar Adobe Driver Version 4.1 (Build 0001) JVM Details Java Version 1.8.0-ea Java Ven
I have a website that has both Classic ASP and ColdFusion screens in it.I am moving the site from Windows Server 2003 to Windows Server 2008 R2 64-bit.One of the asp screen uses SA-FileUp to upload files, so I loaded the trial version of SA-FileUp onto the server to make sure it will work.I got the SA-FileUp function in the Classic ASP screen to work but the ColdFusion screens stopped working.I changed the IIS Application Pool "Enable 32-bit Applications" from True back to False and the ColdFusion screens work but the SA-FileUp function on the Classic ASP screen does not work.How can I get the ColdFusion screens and the screen with SA-FileUp in it to both work?
I am trying to install CF 11 on a windows 2008 R2 Standard SP 1 server (This is a new server that does not have any websites on it yet). The initial install has no errors and ask if you want to finish the install by going to the administrator. I click ok. It goes to https://hostname/CFIDE/administrator/enter.cfmThe webpage it goes to is titled "Configuration and Settings Migration Wizard" "ColdFusion has been successfully installed. This wizard will guide you through the remaining server configuration steps and, if applicable, migrate settings from a previous version of ColdFusion.To guarantee the security of your server, please enter your ColdFusion Administrator password. "I type in my password and it says it is invalid... I KNOW it is correct. I have uninstalled CF twice now with the same results. The page looks a bit odd though. The box is blue and the text is black. Making it hard to read. The test also looks to be pushed down a bit (Like an image would go there, but there i
I am working on calling web service from Cold Fusion 10 and ran into the following error:415 Cannot process the message because the content type 'application/soap+xml;charset=UTF-8;action=http://webservices.host.com/API/2012/10/SchemaService/GetSchemaBySystemName' was not the expected type 'multipart/related; type="application/xop+xml"'.I was able to run the same call using SOAP UI. Below is the code related to this call in ColdFusion:------------------------<cfhttp url="https://[hostname.com]/API/SchemaService?wsdl" method="post" result="httpResponse"> <cfhttpparam type="header" name="content-type" value="application/soap+xml;charset=UTF-8;action=http://webservices.host.com/API/2012/10/SchemaService/GetSchemaBySystemName"> <cfhttpparam type="header" name="Action" value="Apache-HttpClient/4.1.1 (java 1.5)" >  
I have a 64bit VM windows server running Windows Server 2008 R2.I installed Oracle drivers for both 32bit and 64bit. Have TNS for both setup for my Oracle database.The setup of the datasource, verified fine. The web application will connect fine to the database and works sometimes against it.But will error out at some point, error is: [Macromedia][SequeLink JDBC Driver]TCP/IP error, connection refused. The database is not the issue since this application and database is running perfectly on an older server that is being decommissioned.I had first tested with the Coldfusion trial version and everything worked perfectly without error. Problem appeared to be introduced after setting the license key. Also, in the trial version, I was not using the ODBC socket, but there was specifically an Oracle typeavailable. Help with this would be very much appreciated - I am stuck. Thanks Scott
Hello, I am trying to use CFC generator to generate ORM script cfc. I select tables from the RDS view, then enter location and then see the screen with tables where I can specify relationships. When I click on generate, I get an error message Error : Array index out of range: 5, where (5) is always number of tables displayed in the screen -1.
I have a MySQL named Natural Systems which is a magazine account that it member's will both sell handmade items wherein the proceeds will go into the Natural Systems account and each member also give a weekly donation. All of the proceeds will help toward the printing of the subsequent volumes. both of the selling of handmade items and the weekly dues happens during the same week or the same magazine volume number. I am trying to write a query that will pull both of the sales as well as the weekly dues payments weather they have paid or not. SELECT foiid, trim(concat(name.fname,' ',name.lname)) AS no_ns, nspayamt, DATE_FORMAT(nspaydate, '%m/%d/%Y') FROM name LEFT JOIN nspay ON nspayfoiid = foiid and volume = '27' WHERE nspayfoiid is null AND type = 'Registered' AND city = 'richmond' AND status = 'a' group by foiid ORDER BY no_ns This code will bring up the following names of those who did not pay weekly dues during volume 2: Christopher GabbMichael banksTimothy Ha
Is it possible to use markers/special identifiers in Cold Fusion? If possible how do I test for markers at the end of say a zip code. E.x. 11691XX( XX is the special Marker).
Hello,I am trying to remove all html from a user input string.something like this:<cfset string ="sample text &lt;a&gt;">I have tried:Replace(string , "<[^>]*>", "", "ALL")Replace(string , "&lt;br &##x2f;&gt;>", "", "ALL")Neither remove the html, can anyone help?
I don't know if this is even possible but thought I would put this out there and see. I took over a web design position. A few sites have some work that was done in ColdFusion8. I have found a link to a login for it, but have no idea about a password, and neither does anyone else in the office here. It seems to be an online application? I have updated the adobe profile for my email account, but that didn't help. Thoughts, ideas, suggestions?
Hello,I have some .cfc's that reside in the same directory as the .cfm file calling them. Everything works as expected, but now we are changing the structure of our web site and cfc paths are not working. I have spent hours trying to figure this out and still no solution. The current (working) path to the cfc is:wwwroot/data/historical/stateplane/select.cfcwith the domain looking like this:http://surveyor.website.org/data/historical/stateplane/select.cfcWe are changing our the structure to, (which throws an error when looking for the cfc):wwwroot/surveyor/data/historical/stateplane/select.cfcwith the domain changing to:http://website.org/surveyor/data/historical/stateplane/select.cfcThe sel_stateplane.cfm page has the following code calling the cfc, which lives in the same directory:<cfselect name="TOWNSHIP_RANGE" bind="cfc:select.getTownship()" bindonload="true" value="TOWNSHIP_RANGE" display="TOWNSHIP_RANGE" />But with the added /surveyor folder after the root, it no longer wor
I am tying to keep an already developed search running. I have no experience. Please help!My error is coming from here:<cfif trim(form.criteria) is not ""> <cfset collectionname="#form.p_collname#"><cfsearch collection="personify_methods" name="getMethods" criteria="#Form.Criteria#" maxrows = "100">Could some one please assist me?
We are running CF 11 Standard on IIS 8.5. I was able to make changes to the ColdFusion11\wwwroot\WEB-INF\web.xml and ColdFusion11/config/wsconfig/1/uriworkermap.properties and this works for East West Urban Managment with index.html in the address but if we don't have that in the address CF doesn't seem to know it should handle that page. http://www.eastwestfun.com/.What am I missing?
We are working on getting ColdFusion 11 to work with JBOSS EAP6.3, as a JEE/J2EE installation. The Coldfusion 11 has a CF Server Java Class Path and a Java Class Path. How can the Java Class Path be configured in this setup? Setting the JVM classpath with the -cp option appears to update the CF Server Java Class Path..
Hi. We are still running CF9 and have noticed that HTTPS calls to web services using the newer SHA2 algorithm fail. It appears that CF9 cannot support SHA2. Does anyone have a suggested patch for this issue. Obviously we need to upgrade to CF11, but that will take a couple weeks. Looking for an immediate work-around. We have two installations of CF9 - one enterprise and one standard edition. Any ideas?
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.