Questions
Recently active
Can I upgrade directly from ColdFusion 9 Enterprise to ColdFusion 11 Enterprise without going to 10 first?For those who have done this,1. What quirks did you find that you had to overcome in your installation (I know that everyone's environment is different and produces differest results)?2. What part of your code broke for which you had to find fixes?Tips and suggestions for a smooth installation, besides following the installation document. Thanks!
I created a adobe dynamic xml form and I also created a sample cold fusion script which reads all the fields from the pdf and populates them in to a structure.<cfpdfform action="read" source= "FORM PATH" result="formData" /><cfdump var="#formData#" label="formData" />When I run this script the structure shows me blank fields.Cold fusion version is 8.Please share your thoughts on this.Many Thanks,Nav.
I've inherited a ColdFusion 10 application with an Oracle 11g backend; Windows server. I am mostly a DBA and not a ColdFusion expert. In the code for the application, they have the datasource hard coded. This means when I move it to Test I must change the datasource, upload the modules, and test. After a successful test, I have to change the datasource, yet again, upload and have it promoted to production. I seem to remember in the old application I used to support, the code was generic and the datasource depended on what server you were on; if on development, test, or production you didn't have to worry. I don't remember how this was done. What would be the best way to eliminate this hard coding and have it more automated? I know I'm probably missing something, but you all have been very helpful to me in the past few weeks, so hopefully, it's not a completely stupid question. Thank you.
Hi CFers,I have this form, and I have which send information to a web service:How I can?FORM<input type="text" name="name"><input type="text" name="cpf"><input type="text" name="inscricaoEstadual"><input type="text" name="email">WS<xs:complexType name="cliente"> <xs:sequence> <xs:element minOccurs="0" name="name" type="tns:clienteContato"/> <xs:element minOccurs="0" name="cpf" type="xs:long"/> <xs:element minOccurs="0" name="inscricaoEstadual" type="xs:string"/> <xs:element minOccurs="0" name="email" type="xs:long"/> </xs:
We are starting to upgrade from CF 9 to CF 11 and have run across several applications that are not loading the js files that the ColdFusion UI tags use from the /CFIDE/scripts folder. Has anyone run across this issue?
CF10/Win2008R2/IIS7.5. Server monitor always shows my "Template cache hit ratio" is 0%. Why? I have all profiling enabled. My template cache count is up to around 700, with a max set of 2000. Surely some of my cached templates are being hit more than once?
CF 11 gives me empty string value for #CGI.Path_Info# in all the subdirectories. It worked for CF9.This is the code i use:<cfparam name="documentsTemplate" default="#GetDirectoryFromPath(cgi.PATH_INFO)#" />And the result of:<cfdump var="#documentsTemplate#"> or<cfdump var="#cgi.PATH_INFO#"> is:[empty string]I read it was the same issue for CF10.Do you know the reason and the way to fix it? Thanks a lot
HiHopefully, some one can help me with this issue. I am trying to implement a global site and hence was looking for a way to detect user location. I do not want to use any ip2location webservice or download a database or ask for user to "share location".Anyways, I found this project. I implemented it , it detects my location correctly (US). However for my friend in Germany it is returning an empty string for Country.http://javainetlocator.sourceforge.net/. I am using jar file from here. http://sourceforge.net/projects/javainetlocator/files/ with version 2.23I am using CF 11 and my code is onhttp://roomdu.com/geolocator/PLEASE SUGGEST ME <cfset ipAddress=cgi.REMOTE_ADDR> <cfset geoLocator=createobject("component","remoteClassPath_geoLocator")> <cfset Ok=geoLocator.init()> <cfset thisLocal
In order to access a secure FTP site, I need to specify a port (8080) for the proxy. There is no parameter for proxyport. I tried appending it with a colon (i.e., proxy.server.com:8080), but that didn't work. Via WinSCP, I can connect just fine since I can specify a proxy port in that app.How do you specify a Proxyserver Port in CFFTP?
This and similar queries have worked for years. The are 5120 similar queries in the system this came from according a DW search of "<cfquery name" This is the returned SQL error from the robust error message (on Development server). The actual SQL error message stated that nProb was not a designate field, which of course it true. nProbID should have been a number; e.g., 4472.As you can see, most of the CF vars have substituted -- only the highlighted ones have failed. I've been doing CF since the summer of '98. While I've had thousand of error and odd things happen, I have never had this happen before. I've tested the sources for all the errant (?) vars, but to not avail.Follow-up: I figured out the cause. The form.vars that these four values (sUserId, nProbID, scurType, and sScreenName) came from were on the previous page and for whatever reason, they were not with a <cfoutput> .
Our CF10 Windows server crapped out last night with a Tomcat error to the effect of 'the service is not running' (rather than a 500 from IIS or something). Found this in coldfusion-error.log:Nov 13, 2014 12:03:41 PM org.apache.catalina.loader.WebappClassLoader checkThreadLocalMapForLeaksSEVERE: The web application [/] created a ThreadLocal with key of type [coldfusion.util.DateUtils$1] (value [coldfusion.util.DateUtils$1@101c628c]) and a value of type [java.util.GregorianCalendar] (value [java.util.GregorianCalendar[time=1418457600000,areFieldsSet=true,areAllFieldsSet=true,lenient=false,zone=sun.util.calendar.ZoneInfo[id="America/Los_Angeles",offset=-28800000,dstSavings=3600000,useDaylight=true,transitions=185,lastRule=java.util.SimpleTimeZone[id=America/Los_Angeles,offset=-28800000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=3,startMonth=2,startDay=8,startDayOfWeek=1,startTime=7200000,startTimeMode=0,endMode=3,endMonth=10,endDay=1,endDayOfWeek=1,endTime=7200000,endTimeMo
We are upgrading from CF9 to CF11. CF9 is running on an older server under Windows Server 2003. I'd like to install CF11 on a new server under Windows Server 2012 and then shut down the old server. But since we're getting the upgrade price, will I still be able to install it on a new machine that didn't previously have CF9 installed?
I am getting the following error on the /home/coldfusion9/logs/application.log.----------------------"Warning","jrpp-133","11/09/14","22:11:52","CFADMIN","Unexpected characters found in locale.""Warning","jrpp-133","11/09/14","22:11:52","CFADMIN","Unexpected characters found in locale.""Warning","jrpp-133","11/09/14","22:11:52","CFADMIN","Unexpected characters found in locale.""Warning","jrpp-133","11/09/14","22:11:52","CFADMIN","Unexpected characters found in locale.""Warning","jrpp-133","11/09/14","22:11:52","CFADMIN","Unexpected characters found in locale."----------------------Any idea what is causing it and how can I stop it.I am using coldfusion9 along with CentOS release 5.10 and plesk 12.I have protected the CFADMIN directory as a password protected one.Let us know the valuable thoughts regarding this.Thank you,
<!---Control the timeout---><cfsetting requesttimeout="600"><cfset thisDate = now()><cfset today = #DateFormat(thisDate,"mm-dd-yyyy")#><!--- Open ftp connection ---> <cfftp connection="MyFtp" server="#FTPserver#" username="#username#" password="#password#" action="Open" stoponerror="Yes"> <cfftp action="listdir" stopOnError="Yes" name="Files" directory="/export400" connection="MyFtp">
Hi,Using cfcache to cache templates for a short period of time, the number of threads in coldfusion.exe process increase unexpectedly. Moreover, these threads remains in process (view resource monitor). We don't know why. Maybe an xml config file of CF10 take control of these threads?When I use this code:<cflock name="prodDetail#URL.ID#" type="exclusive" timeout="10000"><cfcache timespan="#createTimeSpan(0,0,0,30)#" key="prodDetail#code#" id="prodDetail#code#" name="prodDetail#code#">........</cfcache></cflock>Thanks in advance.
Just wondering if it is possible for a slide to contain a background image and have text appear on top of it?I've tried many ways and each time, the image is being displayed on top of the text.Examples I've tried: <cfpresentationslide Title="FILE BACKGROUND" duration="14" presenter="Paul"> <html> <body background="file:///C:/inetpub/wwwroot/ppt_test/slide_header.jpg"> <h3>Sales</h3> <ul> <li>Overview</li> <li>Q1 Sales Figures</li> <li>Projected Sales</li> <li>Competition</li> <li>Advantages</li> <li>Long Term Growth</li> </ul> </body> </html> </cfpresentationslide> and <cfpresentationslide Title="DIV" duration="14" presenter="Paul"> <div style="background-image: url('slide_header.jpg'); width: 960px; height: 124px; color: ##000000; z-index: -
We will be upgrading from ColdFusion 9 to 11 Enterprise edition. Can we use the same licensing keys or do we need new ones?
ColdFusion 10 Update 14 causes an application pool stoppage on one of our 2012/IIS8.5 servers. Has anyone else had any issues? We had to roll back to update 12.Regards,Mark
Hi,I have installed Cold Fusion 11 in a developement environment.I noticed that there is an update for a security issue.I am unable to locate the update (security fix) for Cold Fusion 11.Does any one know where the update is located so I can download it?Thanks for your help,Mike
Hi,First, apologies if this (or a similar version) ends up posted here twice.I am trying to install CF11 (ColdFusion_11_WWEJ_linux64.bin) on a Scientific Linux machine and am getting the following, as it craps out:Preparing to install...Extracting the JRE from the installer archive...Unpacking the JRE...Extracting the installation resources from the installer archive...Configuring the installer for this system's environment...Launching installer...JRE libraries are missing or not compatible....Exiting....My java version is:java -versionjava version "1.7.0_71"OpenJDK Runtime Environment (rhel-2.5.3.1.el6-x86_64 u71-b14)OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)Do any of you have any suggestions as to what I need to do to get this to install?Thanks,Steve
I keep forgetting on how to order a column with datatype varcharOne of my column for pricing has these values: 5,12,15,18,21,23,31 etc when I cfoutput my query result I got the list showing as: 12,15,18,21,23,31,5It should be from less price to higher prices: 5,12,15,18,21,23,31 but I can't make this happening because the datatype for this column is varchar.I know there is a way around but I can't remember, can someone help me?My query is real simple:select ranges, pricesfrom feesorder by prices and this doesn't work
I m facing issues in my application because < , > and " are being converted to &lt , &gt and &quot respectively.Please tell me why this happens and how to prevent it from happening.Thanks in advance.
Hello, We configured with Coldfusion 10 Tasks that send mail using SES (Amazon) with username and password and validated. We launched the task and will manage coldfusion sending emails every x time processing them. In Coldfusion log we are seeing this error is repeated, albeit that finalment eventually send all emails pending queue, "Error", "scheduler-1", "10/23/14", "15 : 05: 19 ",," javax.mail.MessagingException: Could not connect to SMTP host: email-smtp.us-east-1.amazonaws.com, port: 465, response: -1 " A which may be due to this error? because users have reported to us that do not receive emails. Regards and thanks for yours answers
I'm trying to install security hotfix APSB14-23 per this page for my ColdFusion 9,0,0,251028: http://helpx.adobe.com/coldfusion/kb/coldfusion-security-hotfix-apsb14-23.htmlThe problem is when I get to step 5 (Stop the ColdFusion instance) I cannot find "ColdFusion 9 Application Server" listed in services.msc. Little confused as my ColdFusion sites are up and running fine. Is there another (correct/complete) way to stop the ColdFusion instance? Thanks for any help!
This might be obvious, but I'm not finding a way to view an archive of my posts. The original forum format had this feature. Anyone know if there is a button to view this?
Remix with Firefly Community Gallery
Thousands of free creations to fall in love with and remix in Firefly.
Already have an account? Login
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.