Acrobat install fail

New Here ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

I am running Mac OS Mojave 10.14.6 and just upgraded my Adobe subscription and cannot install Acrobat. Installer went to @50% and just cut out. Very frustrating. Any help appreciated. 

Views

23

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

LATEST

https://helpx.adobe.com/acrobat/system-requirements.html

 

Acrobat cannot be installed on Mojave. It requires macOS Catalina 10.15 or later.

 

You'll have to upgrade your operating system or your computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

Make content for your business needs with Adobe Express.

Get started easily with free templates: