• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

buttons showing up over pop-ups - fixes don't work

New Here ,
Feb 24, 2017 Feb 24, 2017

Copy link to clipboard

Copied

I'm building an interactive PDF and I am having an issue with a button showing in front of a pop-up window (which is itself a button). 

I understand that there is a bug regarding stacking order in InDesign and I have employed all workarounds that were suggested through various sources (order of which buttons are made, setting the tab order, editing the order in Acrobat, plus ensuring all my software is up-to-date) and the problem is that the button does appear behind the pop-up, but it only happens once. If I close the pop-up and click the button to open it again, the button returns to the front. 

I figured out a workaround to hide the button when the pop-up is activated and then to show it when the pop-up is closed, but I'm preparing to make a file with several buttons per page and applying all these show/hide button actions to each button is going to be tedious. 

Have there been any updates to this situation?

TOPICS
Create PDFs

Views

1.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 25, 2017 Feb 25, 2017

Copy link to clipboard

Copied

What happens when you create the buttons in Adobe Acrobat, not InDesign?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 26, 2017 Feb 26, 2017

Copy link to clipboard

Copied

Doesn't sound a bug in Adobe software. Form fields and annotations do not have any defined stacking order. This has changed even on dot releases of Acrobat and had differed between Acrobat and Reader at some times. so the bug is one of expectation. Find a solution that does not depend on overlapping visible fields.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 26, 2017 Feb 26, 2017

Copy link to clipboard

Copied

If you show/hide the fields using a script it will not be too complicated to write one that hides all the other fields on the page when the pop-up is shown, and then show them back when it is hidden. It's even possibly to only show/hide those fields that overlap with the popup, but that's more tricky to calculate.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2018 Jan 08, 2018

Copy link to clipboard

Copied

Hi. I've been having the same problem and tearing my hair out BUT I think I've worked it out!

I've got a grid of images with rollover popups. If my popup overlaps the next image in the grid, it automatically goes behind that next image which I DON'T WANT! After weeks of trawling the internet for a solution (and finding none) I have stumbled across the Set Tab Order box (Object>Interactive>Set Tab Order in InDesign CC) which IMO is a complete misnomer as it actually sets the order of objects!

All my buttons appear in the Set Tab Order box. By ordering these in front of the images, my popups now appear in front.

Fingers crossed this helps you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

I am having the same issue too. I've tried setting the tab order (both ways) and it still happens. I am at my wits end and don't know what to do!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 08, 2018 Jan 08, 2018

Copy link to clipboard

Copied

That’s just good luck. My advice stands: don’t overlap.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2024 May 17, 2024

Copy link to clipboard

Copied

LATEST

Based on the type of document being created, it is not always possible to "not overlap"  Some of my pop-up windows have a lot of content and extend into the area where the buttons are.  Any more suggestions?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines