• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't put digital signature on a protected form with editable fields

New Here ,
Jun 17, 2024 Jun 17, 2024

Copy link to clipboard

Copied

I made a form with editable fields and protected elsewhere, but its user can't put his/her digital signature after having completed it. I also tried to print the completed form as a "Microsoft printer pdf", but even so it is not possible to sign it digitally, because of the protection.

Is it possible to change some parameter somewhere, to state that the document has editabile fields, is protected in every other part to avoid other editing actions, BUT its digital signature is allowed?

TOPICS
Edit and convert PDFs

Views

177

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jun 18, 2024 Jun 18, 2024

It sounds like you created an Adobe Sign form, probably by ticking the box that says "This document requires signatures" when creating the form.

Click on Tools - Prepare Form and then click on "More" at the right side of the window and then on "Revert to Acrobat Form". In the future, do not tick that box, as that converts the file to the more limited Adobe Sign format. Just add the Signature fields manually.

Votes

Translate

Translate
Community Expert , Jun 18, 2024 Jun 18, 2024

That one is not relevant to this issue.

Votes

Translate

Translate
Community Expert ,
Jun 17, 2024 Jun 17, 2024

Copy link to clipboard

Copied

Yes. When applying the security policy make sure to select this option:

 

try67_0-1718661090437.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

@try67 

Thank you so much for your reply, but I'm sorry it does not work: I had the same settings, but to no avail.

Then, I thought that the trouble maybe came form the lack of any of the two possible "Digital signature" fields in the document (silly me!); so, I put one of them in one page of the form, alternately: first I tried the "Field for electronic signature with space and e-mail adress", then I tried the other "Field for electronic signature". Nothing changed: one can write anything in any of the allowed fields, included that dedicated to a digital signature", BUT can not put a digital signature in the document, because "the document is protected". But I need it to be protected, since I don't want anyone to alter its format, paragraphs, colors and so on!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

It sounds like you created an Adobe Sign form, probably by ticking the box that says "This document requires signatures" when creating the form.

Click on Tools - Prepare Form and then click on "More" at the right side of the window and then on "Revert to Acrobat Form". In the future, do not tick that box, as that converts the file to the more limited Adobe Sign format. Just add the Signature fields manually.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

I'm sorry I was writing the message below, before I could read yours above. It seems a very good suggestion. I'll try that and let you know the results. Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

WONDERFUL, IT WORKED!

The form was digitally signable with an output as p7m. Thank you so much!

BUT ... now the menu "Ad module fields" is greyed out. How can I go on with editing my form?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

What is this menu item? I'm not familiar with it? Can you send a screenshot?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

LATEST

The problem has resolved by itself in a mysterious way: I retryed to save the AcroForm with a new name, then I opened it, put the password to edit it and presto the "Add  module fields menu" is working again!

Thank you very much indeed again, Five stars!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

"I had the same settings, but to no avail": that is not correct, I had "Printing allowed" to "High resolution". I changed it and now I'm waiting for one af my office colleagues to test the form, by trying to put a digital signature in it (since I'm not qualified to do that).

To be updated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

That one is not relevant to this issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines