• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

Mail.app wants to sign using key "privatekey" in your keychain

New Here ,
Apr 14, 2020 Apr 14, 2020

Copy link to clipboard

Copied

I wanted to sign a document using the sign/signature tool but for whatever reason, I ended creating a digital signature by mistake now I can't send the email without attaching a private key. I needed to remove this ASAP. 

 

Adobe Reader doesn't allow me to remove the certificate. i.e clicking on the "Remove Id" does nothing.

 

Screen Shot 2020-04-14 at 11.31.47.png

 

SOLUTION:

 

1. Open Keychain on your mac "search 'keychain' in Spotlight (The magnifying glass icon on the top right of your screen) or Go to >Applications>Utilities>Keychain.app

2. Find the culprit certificate in the list

3. Take a back of the key in case something goes wrong by exporting the certificate.

4. >>> Delete

5. Restart the Mail app and also the Adobe Reader app.

 

Sorted 🙂

TOPICS
Security digital signatures and esignatures

Views

81.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Feb 03, 2021 Feb 03, 2021

Go to "my certificates' and delete them all and then send mail you should be allowed.

Votes

Translate

Translate
New Here ,
Sep 30, 2020 Sep 30, 2020

Copy link to clipboard

Copied

So which key chain is the culprit?  

I've deleted a bunch of them and none of them have the effect.

I really must remove the request to type in my password for each email --it's absurd!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2020 Dec 17, 2020

Copy link to clipboard

Copied

Hi @Lonna5CD0 did you get this resolved.  I am having the exact same issue - it's so annoying.  Trying to solve it.  Any insights would be great.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2021 Feb 06, 2021

Copy link to clipboard

Copied

Hey,

Did you resolve this issue. I have the same problem. I also looked under 'My Certificates' but it was empty. Its so frustrating, I cant send any mail. Thanks! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 03, 2021 Feb 03, 2021

Copy link to clipboard

Copied

Go to "my certificates' and delete them all and then send mail you should be allowed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Huma5DD1's solution (delete items in "MyCertificates" - found under the Category menu in the bottom L of the Keychains window) worked for me.

Thank you so much!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2022 Feb 06, 2022

Copy link to clipboard

Copied

I can't find a section described as "MyCertificates" - where is this located?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 07, 2022 Feb 07, 2022

Copy link to clipboard

Copied

Mine were located in the "login" section under the Default Keychains title, using MacOS Monterey 12.0.1 with a MBA M1.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2021 Apr 20, 2021

Copy link to clipboard

Copied

Wonderful easy solution to a terrible obscure problem.  Thank you!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Worked great so far.

Thanks and Aloha

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 13, 2023 Mar 13, 2023

Copy link to clipboard

Copied

This worked so far.  Thanks.    Amazed that Adobe Pro for all that one spends on it effs-up Mail so badly.  It appears as though one has a choice - use digital certificates or get mail.  PATHETIC.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 31, 2021 Mar 31, 2021

Copy link to clipboard

Copied

This worked a treat!  Thank you 😄

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

Hi,

When you open a new email, you can simply deactivate this digital encrypted signing by clicking on the little blue encircled checkmark in the new mail editor window. If you do this, it will stay unchecked for all subsequent emails. So no need to manually delete digital certificates from the keychain.

(I'm on Big Sur 11.1).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Thank you Jelle5C10, simple and elegant.  I somehow created a monster without intending to, and all attempts to send some urgent documents failed until I found your solution.  Phew! (I am on Monterey 12.0.1).  Please accept a large virtual bouquet of flowers :bouquet:

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 22, 2021 Dec 22, 2021

Copy link to clipboard

Copied

perfect!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2022 Feb 08, 2022

Copy link to clipboard

Copied

This is the correct solution. No need to delete my digital signatures.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Where is this little blue encircled checkmark? I don't see it! I'm on Monterey

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

oh wait - it isn't blue on mine but I found it and that worked!!! Thank you!

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 03, 2022 Sep 03, 2022

Copy link to clipboard

Copied

THIS is the solution that works! thx

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 28, 2022 Nov 28, 2022

Copy link to clipboard

Copied

11/28/2022. I had the same problem after signing a PDF document and trying to send. Found @JelleSDC10 reply, tried it and it could not have been easier. Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2022 Dec 29, 2022

Copy link to clipboard

Copied

Huge thanks Jelle5C10! It solved my problem also. Who would have known if it wasnt for clever heads like you 🙏 The encircled check mark is to the far right in the Subject line. untick it and problem is solved. Big Sur 11.7

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2023 Mar 01, 2023

Copy link to clipboard

Copied

yesss! this is it! they should fix the pinned "correct answer" as this is actually the correct answer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 16, 2023 Jun 16, 2023

Copy link to clipboard

Copied

Thanks Jell5C10,

A Brilliant and simple solution. I was afraid to delete all my certificates. I don't even know what the hell they are.

thansk, Henry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

Thank you! This worked like a charm!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 08, 2022 Oct 08, 2022

Copy link to clipboard

Copied

Delete is not working for me! !@#$%^&* Please help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines