• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
15

Adobe Reader cause error when open pdf file with protected mode on

Community Beginner ,
Dec 12, 2023 Dec 12, 2023

Copy link to clipboard

Copied

Hi,

     When open pdf file with long path and file name (exceed 260 characters) with Protected Mode on, the Adobe Reader (verson 2023.006.20380 64-bits) will report error: "There was an error opening this document. Access denied.". If I disable "Enable Protected Mode at startup", I can open the same pdf file without issue.
If I shorten the path and filename to less than 260 characters, I also don't have this issue regardless of the "Enable Protected Mode at startup" is enable or disable.

    I have no permissions and rename of the folder structure, folders name and filename, so wonder anyone had better solution as I prefer to turn on the protected mode. Also, I already enable the "Enable Win32 long paths" group policy on my computer.

 

   Thanks and have a nice day.

TOPICS
General troubleshooting , Modern Acrobat , View PDF , Windows

Views

253

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 12, 2023 Dec 12, 2023

Copy link to clipboard

Copied

Hi @ywx73 

 

Hope you are doing well and thanks for reaching out.

 

Is the file stored on a shared drive (Dropbox, google drive etc.)? If yes, please try to save the file locally on our computer and see if that works.

 

Also, please go through the help article that i have found on MS support https://learn.microsoft.com/en-us/windows/win32/fileio/maximum-file-path-limitation?tabs=registry and see if that works.

 

Hope this information will help

 

~Amal

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2023 Dec 12, 2023

Copy link to clipboard

Copied

Hi,

    The file is not store under OneDrive or any cloud base drive. Also, I already enable the "LongPathsEnabled" as mention in my first post.

Anyway, I done some more test on my Windows 10 and Windows 11 PC and all have the same result:
1) I copy a pdf file into a long path (path + filename greater than 260 characters) folder in my C (system) drive, I can open the pdf file using Adobe Reader without issue.
2) I copy a pdf file into a long path (path + filename greater than 260 characters) folder in my D and E drive, I encounter error when try to open the pdf file using Adobe Reader.
3) I copy a pdf file into a long path (path + filename greater than 260 characters) folder in my user folders (documents, download, pictures & etc), I can open the pdf file using Adobe Reader without issue.
4) The strange part is the desktop. I copy a pdf file into a long path (path + filename greater than 260 characters) folder in my user desktop, I encounter that error when try to open the pdf file using Adobe Reader directly from the desktop. But if I use the quick access from the Windows Explorer (the "desktop" quick access in the left nagivation panel) tp browse to the files in the desktop, I can open the pdf file using Adobe Reader without issue.

     I record a video showing my testing using my Windows 11 PC:
https://www.youtube.com/watch?v=By5su68l5ac

     Have a nice day.

Adobe Reader problem when open pdf file with long path and filename.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 13, 2023 Dec 13, 2023

Copy link to clipboard

Copied

Are D and E local drives at your system?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 13, 2023 Dec 13, 2023

Copy link to clipboard

Copied

Hi,
     yes... My main computer (Windows 10) have 3 local drives (C: single 1TB SSD, D: single 2TB SSD and E: 2TB mirroring using windows storage spaces). The Windows 11 computer in the youtube video is my another computer which have 2 local drives (C: single 500GB SSD and D: single 256GB SSD). I do the same test on all the drive in both PC and have the same result. 

   Thanks and have a nice day.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2024 Feb 12, 2024

Copy link to clipboard

Copied

LATEST

Hi ywx73!

Try this methode.
First, open CMD and type 

fsutil 8dot3name query d:

 If you get this: "The volume state is: 1 (8dot3 name creation is disabled)" you need to enable 8dot3 name creation on D: drive with the following command: (the default value is 1=disabled)

fsutil 8dot3name set d: 0

 Now, you need to recreate long named folders and try open files. I hope it's fixed your problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines