Adober Reader DC crashing because /usr/lib/libcrypto.dylib

Community Beginner ,
Sep 23, 2021 Sep 23, 2021

Copy link to clipboard

Copied

Hi, since I updated my MacBook to v.11.6, Adobe Reader DC v.21.007.20091 is crashing every time I try to open it. The error message is the following:

 

Process: AdobeReader [16711]
Path: /Applications/Adobe Acrobat Reader DC.app/Contents/MacOS/AdobeReader
Identifier: AdobeReader
Version: 21.007.20091 (21.007.20091)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: AdobeReader [16711]
User ID: 501

Date/Time: 2021-09-23 16:48:57.438 -0300
OS Version: macOS 11.6 (20G165)
Report Version: 12
Anonymous UUID: A9C7C342-E452-6FBD-B5B4-ADB4F803FBE1


Time Awake Since Boot: 160000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
/usr/lib/libcrypto.dylib
abort() called
Invalid dylib load. Clients should not load the unversioned libcrypto dylib as it does not have a stable ABI.

 

Someone knows how to fix this? I've find similar issues in this forum, but no one with a practical way to solve it. 

 

Thanks.

 

TOPICS
Crash or freeze , General troubleshooting

Views

955

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Sep 29, 2021 Sep 29, 2021

use XCode or any other plist editor and remove everything under DC/Security/ASPKI (click on Item 0, Item 1 and delete (Fn backspace)). Worked for me, thank you very much @Prashant. 

Likes

Translate

Translate
Adobe Employee ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

Hi Celso

 

Hope you are doing well and sorry for the trouble.

 

This issue is already reported to our engineering team and they are working in it to find the fix.

 

We will share the update as soon as we will hear anything from them.

 

Thanks for your time and patience on this

 

Regards

Amal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

Thanks Amal. I'll be waiting for the fix.

 

Best regards.

 

Celso.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 24, 2021 Sep 24, 2021

Copy link to clipboard

Copied

MOVED TO THE ACROBAT READER FORUM

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

Hi, I can't find further information how to fix this in the forum.

Do you know where can I find it?

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

Adobe say they will fix it, some day. Meanwhile we must wait. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

I can't do anything, Reader crashes after a few seconds. I tried everthing, symbolic links, copy library, etc., but nothing works

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 27, 2021 Sep 27, 2021

Copy link to clipboard

Copied

I don't say waiting is a good solution, but it's all Adobe have to offer, so far as I can see. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Maybe this will help:

What I have managed to observe in my case is that, if I manually remove the plugin „PPKLite.acroplugin” from the „Plugins” folder, then the app doesn't crash anymore and can be used normally (except the signature part which remains to be fixed). 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2022 May 26, 2022

Copy link to clipboard

Copied

LATEST

Life saver! Thanks for this, worked for me. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Hi @Celso5C9E ,

 

Looks like the etoken module that you are using is not compatible with Reader.

You can first try deleting the entry "Adobe_P11CredentialProvider" in com.adobe.reader.plist located at "/Users/<user directory>/Library/Preferences" under DC/Security/ASPKI. Deleting this key would remove all the pkcs11 modules that you   have attached. Once that is removed your reader would start working correctly . Then you can download and install the latest etoken driver and then try to attach the latest module to pkcs11 module settings in Reader Preferences.

  1. Open Preferenes->Signature – Identities & Trusted Certificates; 
  2. Select PKCS11# Modules and Tokens;
  3. Select Attach Module and then provide the correct dylib path for your etoken.
  4. Select your token provider's name and select Login and type the password of the token.

After that try signing.

Let us know if this helps.

 

Thanks,

Prashant.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

As I have the same problem, could you please let me know how do I actually delete the entry "Adobe_P11CredentialProvider"?

As you can see in the attached screenshot, when I open the com.adobe.reader.plist file, I don't understand where the entry starts and where it ends. I mean, what exactly do I have to delete? 

 

Thank you for your time.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Hi @Roby_B ,

 

You can use any Plist editor to make changes in plist. Common one being Xcode.

If you do not want to delete the entry "Adobe_P11CredentialProvider" or for some reason you are not able to, then you can skip this step and can simply try to reinstall the latest etoken driver from your token provider's website and then try to attach the latest module to pkcs11 module settings in Reader Preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

I installed SafeNetAuthenticationClient.10.2.82.0 and it didn't work

 

Regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Hi @Ubaldo5D3E ,

 

Please make sure it is the latest one released by the SafeNet . You can download the drivers based on your OSX from their official website https://support.globalsign.com/ssl/ssl-certificates-installation/safenet-drivers .

 

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2022 Jan 03, 2022

Copy link to clipboard

Copied

This worked flawlessly! Thank you @Prashant. !!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2021 Sep 28, 2021

Copy link to clipboard

Copied

Mmmmm in /Users/<user>/Library/Preferences,  there is a file named "com.adobe.Reader.plist"
It's not a directory.

The file is a binary file.

The etoken module used it's the clasic safenet etoken, i think that's not the problem.

 

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

use XCode or any other plist editor and remove everything under DC/Security/ASPKI (click on Item 0, Item 1 and delete (Fn backspace)). Worked for me, thank you very much @Prashant. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2021 Sep 29, 2021

Copy link to clipboard

Copied

It works, thanks!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 16, 2021 Oct 16, 2021

Copy link to clipboard

Copied

I successfuly removed the key from the plist and indeed Adobe stopped crashing, however I experienced the same  (or similar) crash while attaching the module. I described the issue into more details here: https://community.adobe.com/t5/acrobat-discussions/adobe-acrobat-reader-dc-crash-when-attaching-modu....

 

Regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 30, 2021 Sep 30, 2021

Copy link to clipboard

Copied

Hi all,

I couldn’t find the file com.adobe.reader.plist located at "/Users//Library/Preferences". The one I’ve found is com.adobe.acrobat.pdfviewer.plist, but it doesn’t contain the entry you mentioned 🙁

Thanks.

Celso.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines