Can I lock in a zoom level (e.g. Page View) so it won't change?

Guest
Nov 06, 2014 Nov 06, 2014

Copy link to clipboard

Copied

I'm wondering if there is a way to prevent Adobe Reader from changing my zoom level.  I prefer to read with the zoom level set to Fit Page.  Every time I click on a bookmark to jump to another page in the document, the zoom level changes to Fit Width (I think).  This is extremely annoying because I have to keep changing the view back to Fit Page.  In preferences I have put the default zoom to Fit Page, but that only determines how it comes up initially.  When I click on a bookmark it changes again.

I don't understand why the zoom changes when you click a bookmark at all.  Why would I want the zoom to change on me?

FYI, I'm using Reader XI (11.0.08).

Thanks for any help/suggestions.

Views

34.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Nov 06, 2014 Nov 06, 2014

Using Acrobat (not the free Adobe Reader) you can set the page magnification (and many other things) for Bookmarks, links, Comment annotations and more.
As well, using Acrobat (but not the free Adobe Reader) you can create Bookmarks.

Need to know for Adobe Reader:

The free Adobe Reader cannot create PDF.
The free Adobe Reader cannot export PDF page content.
The free Adobe Reader cannot manipulate PDF page content or add/remove features such as links, bookmarks, etc.


Using Acrobat you'd have to con

...

Likes

Translate

Translate
LEGEND ,
Nov 06, 2014 Nov 06, 2014

Copy link to clipboard

Copied

Using Acrobat (not the free Adobe Reader) you can set the page magnification (and many other things) for Bookmarks, links, Comment annotations and more.
As well, using Acrobat (but not the free Adobe Reader) you can create Bookmarks.

Need to know for Adobe Reader:

The free Adobe Reader cannot create PDF.
The free Adobe Reader cannot export PDF page content.
The free Adobe Reader cannot manipulate PDF page content or add/remove features such as links, bookmarks, etc.


Using Acrobat you'd have to configure the properties of Bookmarks to provide the desire page magnification / page view.
Sometimes placing a feature (Bookmark, whatever) results in a default setting that you may have to reconfigure back in the feature's Properties dialog.

Remember, at its core, Adobe Reader is a "viewer". 


Be well...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 06, 2014 Nov 06, 2014

Copy link to clipboard

Copied

Thanks CtDave.  I don't have anything besides the free reader, so I did some further research on the web and found a solution that is pretty "brute force", but is an option for others that only have the free reader.  Here is a link to the full description:

http://superuser.com/questions/306803/zooming-size-of-pdf-files-and-bookmarks

Here is the basics:  You can use a text editor and edit the PDF file.  Once in the text editor you can search for /FitH or /Fit (there surely are other codes, but those are the only ones I know of).  These are codes that tell Acrobat what kind of zoom level to apply to the destination of a jump.  So the bookmarks should all have these.  Simply do a search and replace with /XYZ.  The /XYZ code tells Acrobat to leave the zoom level as it already is.

It might sound a bit weird, but I tried it on multiple files I was having trouble with and it worked great.  Of course, my suggestion would be to make backup copy of the file before doing this in case something goes wrong.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2019 Oct 15, 2019

Copy link to clipboard

Copied

Thank you very much, moonan. This helped me a lot. Throughout the years I had this zoom problem and I am glad this issue got solved on the bookmarks, however I still have the same problems on the links. I will try to find a way (and share it here) to mark all the links so one can keep the same zoom level when jumping between the bookmarks/links. Thanks again, this helped me a lot! ^_^

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2021 Mar 07, 2021

Copy link to clipboard

Copied

Thanks! Unlike the so-called "correct answer" (which is not an answer at all, and completely evades the question), your solution actually works! After wasting, egad, about 8 hours struggling to fix this problem, I just opened the file in HxD (a free hex editor) and globally replaced 130 copys of "/Fit" with "/XYZ" and voila, clicking bookmarks no-longer changes zoom.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 06, 2014 Nov 06, 2014

Copy link to clipboard

Copied

Does that also happen if you set the Zoom Preferences to 'Fit Page'?

ar_fit_page.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 06, 2014 Nov 06, 2014

Copy link to clipboard

Copied

Pat,

Yes, it does.  That setting tells Acrobat what zoom level to use by default when you first bring up the file.  I actually have the Fit Page setting in my preferences just like you show.  But once you hit the bookmark, the zoom level changes to whatever the PDF was created with for that bookmark.

I did find that I had a bunch of PDF files that have the bookmarks set to Fit Page, but in a file that has its bookmarks set to something else (like Fit Width), it will always change the zoom when you click the bookmark.

If you are interested, I just posted a crude way to modify this in your PDF files.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2015 Sep 14, 2015

Copy link to clipboard

Copied

Rnoonan, where is that post? I have the same problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jan 28, 2016 Jan 28, 2016

Copy link to clipboard

Copied

KiloRomeo, sorry for the delay in a response, I just saw your question.

The post I was referring to was a couple of replies prior to your reply.  It is a brute force method using a simple text editor and it has worked well for me when I used it.  The full description can be found here:

adobe reader - Zooming size of pdf files and bookmarks - Super User

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 23, 2019 Apr 23, 2019

Copy link to clipboard

Copied

Ok, here is a reverse logic trick that works for me using reader DC free

"Dennis says

November 5, 2018 at 1:23 pm

Mursel and Obi, try de-selecting the “Always use zoom setting” checkbox in the Accessibility tab and it should default to whatever you have selected on the “Page Display” setting."

I hope this saves you the untold hours of frustration I & many others have lost trying to resolve this idiotic oversight by Adobe developers.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

That sounds genius. Where is the "Accessibility tab"? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 16, 2020 Sep 16, 2020

Copy link to clipboard

Copied

Under Edit (or the Reader menu on an Mac) - Preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2020 Oct 05, 2020

Copy link to clipboard

Copied

This does not work. It sets the initial zoom level, but clicking a bookmark returns to the default. For me, that is "fit page" although I'd like it to be "fit width" for my size monitor. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 06, 2020 Oct 06, 2020

Copy link to clipboard

Copied

You can't "lock" the zoom level, but you can set the bookmarks to not change it by setting them to have the Inherit Zoom setting. You can't do that with the free Reader, though. You'll need Acrobat or an external tool, like this (paid-for) one I've created: http://try67.blogspot.com/2011/12/batch-edit-zoom-level-in-bookmarks.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2021 Mar 07, 2021

Copy link to clipboard

Copied

Re "You can't "lock" the zoom level": Sure you can. Open pdf in hex editor and do global replace /Fit -> /XYZ and save to new file. That turns-off event-driven zooming so that zoom is controled ONLY by global setting ("whole page", "page width", "100%", or whatever you set it to). It also bypasses document-editing lockouts because Adobe products are not being used to edit the file. Brute force works wonders.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

LATEST

I don't think the answers below show a real solution, but a trick is to adjust the size of acrobat reader so that the width of the window becomes smaller and fit to width becomes similar to fit to page.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines