Cannot change comment author in properties

New Here ,
Mar 25, 2018 Mar 25, 2018

Copy link to clipboard

Copied

Hello

I have been looking at all the suggestions for changing the author of a comment, since I too do not want my computer login name as the default.

I have tried unchecking the "Always Use Login Name for Author Name".

I have also tried creating a new comment and right clicking on it to display the properties box. However, where I should be able to enter the new name in the Author box, I cannot - it simply won't let me - therefore I can't click "Make Properties Default".

Am I missing something? Is it something to do with allowing Admin controls? It doesn't make sense to me.

I am using a MAC and version 2018.011.20038 of Acrobat Reader.  Any help would be appreciated. I need to find the solution so I can submit an assignment. Thank you.

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 25, 2018 Mar 25, 2018

Copy link to clipboard

Copied

Make sure the comment isn't locked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2018 Mar 27, 2018

Copy link to clipboard

Copied

Screen Shot 2018-03-27 at 16.05.14.png

Thank you for your reply - it isn't locked though. This is a screen shot of the dialogue box that comes up. Any other suggestions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 27, 2018 Mar 27, 2018

Copy link to clipboard

Copied

I'm seeing the same behaivour. It might be a bug or a feature... Either way, you can do it using a script and then change the default properties.

To do it select one such comments (by clicking it in the Comments List), and then press Ctrl+J and paste the following code into it:

this.selectedAnnots[0].subject = "New name";

Then press Ctrl+Enter. That should edit the comment's Author value. Then you can go to its Properties and tick the Make Properties Default box.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 27, 2022 Jul 27, 2022

Copy link to clipboard

Copied

LATEST

I am having the same problem with Acrobat Pro DC 32-bit Windows.  I have the always use login name for author name unchecked.  I also have my name typed in the Name box in the Identity section of the preferences, but it using a name from a previous employee.  Furthermore, it won't let me edit the properties of the comment and change it or change the default. Is there a way to start fresh with my preferences for the program?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines