• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

How To Disable Ctrl + Shift + S (Save As)

New Here ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

Good Evening,

I have a requirment to allow viewing of a secured PDF file. This PDF has the following document restrictions;

Printing: Not Allowed

Changing The Document: Not Allowed

Document Assembly: Not Allowed

Content Copying: Not Allowed

Content Copying For Accessability: Not Allowed

Page Extraction: Not Allowed

Commenting: Not Allowed

Filling of form fields: Not Allowed

Signing: Not Allowed

Creating of Template Pages: Not Allowed

 

I have locked down the Adobe Reader menus.

When I launch the PDF Within Adobe Reader and press Ctrl + Shift + S. Is there a way to prevent this from occuring. If not, is there a way to have the Save As box blank and not allow the function to actually save the file.

 

I was going down the route to disable the Ctrl,  Shift and S keys using Scancode Maps, but that was going to cause more problems in the long term then it is worth.

 

Any advice is most welcome.

 

Kind Regards,

 

John

TOPICS
General troubleshooting , How to , View PDF , Windows

Views

1.0K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

Not possible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

G'day Bernd, thanks so much for your prompt reply. As you suggested it is not possible. Is there any other method you can suggest, other than disabling the Ctrl + Shift + S key combination, that will get me close to the result I am after?

Cheers and thanks in advance

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

What are you trying to achieve, exactly?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

Good Morning try67,

Thank you for the interest in this. What I have is Adobe Reader published as a Citrix Published Application on a dedicated server for this role. This instance of Adobe Reader will only ever launch one single PDF.  The PDF is licenced to a certian number of concurrent users. Within Citrix, concurrent users are controlled. I have continued to lock down the instance of Adobe Reader as much as I can, however the last thing to lock down is this Ctrl + Shift + S key combination to prevent any user attempting to save a copy of the PDF.

As mentioned previously I tried using Scancode Maps, but that was going to cause more problems for anyone logging onto the server. Even if I locked out the 'Shift' key alone (or even Ctrl or S alone), should an admin require login to the server with this password containing upper case letters this could end up causing more issues then it is worth.

If I can disable a key combination that would be my golden ticket.

Cheers

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 20, 2022 Dec 20, 2022

Copy link to clipboard

Copied

LATEST

In order to view a PDF file it has to be saved, either locally or on a network drive, so I don't see this can work. It is possible to hide the Save/Save As menu items, but pressing Ctrl+S or Ctrl+Shift+S, or clicking the Save icon in the toolbar will still work, even if you do that...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines