Problem with adding certificate-based digital signature - Acrobat freezes

New Here ,
Apr 11, 2021 Apr 11, 2021

Copy link to clipboard

Copied

Background:
I often have to digitally sign PDF documents, using the certificate-based signature. It is the standart of e-signatures, developed by our goverenment, which is used for identification. It works by putting the national ID document provided by government into the USB smart-card reader, which activates certificates. Then it is possible to digitally sign documents and use government services online while the card is in the reader. 

The Guidelines provided by government advise to use a third-party software to sign the PDF documents, or to download a certain Adobe Acrobat Reader from government server (which I believe is modified tweaked version, so I prefer to not install it). 
However, I've been using normal Acrobat Reader to put the singatures, and it worked totally perfect at first. After you select the certificate and put the signature, Acrobat Reader asks to save a new file, then this software (CryptoCard Monitor), which is given by government and is associated with card-reader pops-up, asking to enter card's PIN, after which the new file with signature is succefully generated.

The only thing I needed to do, is to add this government certificate root to the trusted directory, so the signed files been diplayed as "valid signature" wih green tick. This was not vital step, but more like for aestethics. 

 

But then the problem started.

Then after few weeks suddenly I encountered a problem. The Acrobat Reader stopped signing the documents successfully. Now when I select the certificate and click sign, it asks to save a new file as usual, and after I click Save, the program freezes. Nothing happens and the coursor is just spinning forever, while Acrobat Reader says "Program is not Responding". Only when I forecefully close it manually, the Card Reader software pops-up and asks for PIN code. However, when I open the newly saved PDF file I find out that it is not signed, and it displays an error related to "BER encoding" .
Unfortunaetly nothing I tried did help me. I completely uninstalled and performed clean installation. I re-installed certificates and resetted other third party softwares. But unfortunately I can not sign documents anymore using Acrobat Reader. Now I have no choice to use the software called "JSignPDF" which the government advises, but it is too old and uncomfrotable. I wish I could go back to sign documents using Acrobat Reader. Do you have any idea what else I could try to restore this ability? I found similiar problems in forums, but nothing helps me... 
Would appreciate any advices. Thank you.  



 

TOPICS
Crash or freeze , Security digital signatures and esignatures

Views

71

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation