• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Problem with default paper size on printer

New Here ,
May 13, 2024 May 13, 2024

Copy link to clipboard

Copied

Hello.

I have a problem with default paper size for my Xerox printer. It seams somehow it keeps changing back to Letter instead of A4. I've read tens of treads and nothing helps.

Printer is XEROX, Win 11, Adobe Acrobat 64bit.

Each time I have to go to Page Setup > Paper size and change the size to A4.
My regional settings is not set to US. I even changed the system locale in administrative language settings, I removed US keyboard, I manually changed in printer preferences each and every printer there is (from Fax to Xerox, Adobe PDF, Microsoft to PDF,  etc..) to A4 in both printer preferences (defaults) and printer printer properties. I also tried to reinstall the Adobe. I also reinstalled XEROX printer. Nothin helped.

Printer itself has A4 in its settings on the device (also the region is Croatia, the format is Metric not US). 

Its crazy that in 2024 this is not solvable...

TOPICS
General troubleshooting , How to , Windows

Views

54

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , May 15, 2024 May 15, 2024

Maybe someone will find it usefull so I'll write how i solved the problem. At least it looks solved for now.


The issue seems to be in the Windows regional settings.
If you used English (United States) as language settings (usually it should only be if regional settings are set to US, but it seems that windows display language and other language settings as well could cause the problem somehow). So, If you have this settings, the paper size will be set to Letter (vice versa for people that have pro

...

Votes

Translate

Translate
New Here ,
May 15, 2024 May 15, 2024

Copy link to clipboard

Copied

LATEST

Maybe someone will find it usefull so I'll write how i solved the problem. At least it looks solved for now.


The issue seems to be in the Windows regional settings.
If you used English (United States) as language settings (usually it should only be if regional settings are set to US, but it seems that windows display language and other language settings as well could cause the problem somehow). So, If you have this settings, the paper size will be set to Letter (vice versa for people that have problem wiht A4 and want Letter -> they need to switch from A4 region to Letter region).

In order to "clean" the language settings, I changed Windows display language to English (UK), removed US from the preferred languages and also changed Administrativre language settings (system locale and  copy to welcome screen and new user accounts). The regional setting were ok even before, but if you have US, change it to A4 region (as for example UK if you want English).

Make sure that your printers are set to A4 (or whatever you are looking for). You can do it by going to Printers & Scanners and change manually each printer. Consider that in most printers you have to change paper size in multiple places. In Printer properties (both tabs: Device settings and Advance/Printing Defaults) and Printing preferences. You can also do it through Windows Powershell (Win + X and run Terminal (Admin)). I first run the following code:

Get-Printer | ForEach-Object {
  $printerName = $_.Name
  $printConfig = Get-PrintConfiguration -PrinterName $printerName
  [PSCustomObject]@{
  PrinterName = $printerName
  PaperSize = $printConfig.PaperSize
  }

}
After that you can use (depending on what paper size you want for which printer):
Set-PrintConfiguration -PrinterName "Xerox" -PaperSize A4


After that, restart the computer.
When you log in again, remove the printer and restart computer again.
After restart, install printer again (Add device).

It should be ok and the paper size for that printer should be A4 in Adobe.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines