Reader DC - 3D PDF - New nVidia drivers: it doesn't work!

New Here ,
Aug 02, 2018 Aug 02, 2018

Copy link to clipboard

Copied

Hi folks,

We recently proceed to a new OS deployment in our company. We deployed Windows 10 v1803 with Adobe Reader 2018.011.20055.

We encountered problems with 3D PDF files on the following computers:

Motherboard: Supermicro X9SRA

CPU: Intel i7-4820K

GPU: Nvidia GT 640 with drivers 398.82  (released 1st August 2018)

It doesn't work at all !

I've checked on other workstations with Windows 10 v1511 with Adobe Reader 2018.011.20055 and Nvidia drivers v358.91: it works perfectly in that case.

So I tried to install Nvidia drivers v358.91 instead of v398.82 on Windows 10 v1803 and... it works this time !

However, I have other graphic cards that GT640 in my company and can't install this driver on every computer...

Finally, I find a workaround for Windows 10 v1803 with Adobe Reader 2018.011.2005 and Nvidia drivers v398.82: I need to disable "Enable Protected Mode at startup".

This is not a longtime solution for us and we can't stay like this.

Can you tell me if Adobe is working on this problem for future releases?

Kind Regards,

DeltaSM

Views

2.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Aug 02, 2018 Aug 02, 2018
If you want to make sure Adobe are aware I recommend you report it. Feature Request/Bug Report Form

Likes

Translate

Translate
LEGEND ,
Aug 02, 2018 Aug 02, 2018

Copy link to clipboard

Copied

It is clearly nVidia who have a problem to fix. There's nothing in Reader that's specific to any one video card, and bugs in video drivers are depressingly common. Did you report it to them? They have active driver development teams.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2018 Aug 02, 2018

Copy link to clipboard

Copied

I just contact Nivida Driver Feedback with the same message. I doubt that they answer me...

At least, I hope Adobe is aware of this issue and can maybe "talk" with Nvidia

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 02, 2018 Aug 02, 2018

Copy link to clipboard

Copied

If you want to make sure Adobe are aware I recommend you report it. Feature Request/Bug Report Form

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 02, 2018 Aug 02, 2018

Copy link to clipboard

Copied

I do not believe this is an NVidia issue specifically. What I have noticed is that by default Adobe Acrobat DC has the option "Enable Protected Mode at startup" enabled.  This results in Acrobat DC reverting to software rendering mode. So if you have a complex 3D model, with textures, then it will either look very ugly or simply may never load and will crash or hang Acrobat as it tries to load it into its software renderer.

By disabling the "Enable Protected Mode At Startup" option it tells Acrobat its OK to use Hardware rendering and everything works fine.

What possibly may be happening in regards to Nvidia is that perhaps Acrobat is trusting certain drivers, but we the users have no idea what drivers they may be. So it "might" work on some computers, but not on others. However for myself I always see it in software mode on Windows 10, but on OSX it seems fine. So it may be an NVidia thing on Windows 10, possibly due to Acrobat checking for some compatibility etc...  And disabling the option brings back the correct rendering in hardware with all the benefits it provides visually and speed wise.

This was never a problem last year. Everything worked beautifully and my clients were able to produce very high quality 3D PDF documents with textures, environment maps, lighting and complex geometry.

But now due to the changes Adobe has made it has crippled Acrobat Reader as a delivery platform.

I hope this will be addressed sometime soon, as every thread I come across the issue is either dismissed or user are told to disable that option, which is not something I would ever suggest to a user.

This should be tested internally on multiple computers, hardware and drivers and at least suggest to end users what drivers they have tested and verified as being compatible. This is done for most 3D software and I feel that Adobe should be doing this also for Acrobat Reader if they wish it to be taken seriously as a distribution system for 3D content.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 03, 2018 Aug 03, 2018

Copy link to clipboard

Copied

Hello kbar,

Thanks a lot for this nice answer! Are you sure that, once Protected Mode is enabled, Reader DC is launched in software mode?


Can someone of Adobe answer this? This a huge issue in our case... Indeed for now, we can use "old drivers" because we have "old card graphics". However, we will receive new laptops with new Nvidia chipsets which means... new drivers. In that situation, I think we could not use 3D PDF anymore


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jun 14, 2022 Jun 14, 2022

Copy link to clipboard

Copied

LATEST

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines