Slow 3D rendering in Acrobat Reader DC

Community Beginner ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

Hi,

I've created a PDF doc with a 3D annotation. When I open it in Acrobat Reader (v. 18.009.20044), 3D rendering performance is very poor.  The Preferred Renderer is DirectX 9 in the Preferences but, in fact, I don't see any differences between Software and DirectX 9: rendering is very slow in both cases. BTW, I have only two options: DirectX 9 and Software, no OpenGL.

On the other hand, when I open the same file in Acrobat Pro DC, 3D rendering is much faster with the DirectX 9 renderer. When I select Software renderer in Acrobat Pro, the performance is the same as hardware or software rendering performance in Acrobat Reader (slow).

I've tested it on several PCs with different NVidia graphics cards (GeForce GTX 960, GeForce GTX 970, Quadro M2000M with the latest drivers, Windows 10) and got exactly the same result: Acrobat Pro is fast, Acrobat Reader is slow with respect to 3d rendering.

Is it because Acrobat Reader does not support hardware acceleration?

If it does, how can I enable it? Do I have to do something else in addition to selecting DirectX in the preferences?

Thanks,

Roman

Views

27.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Feb 07, 2019 Feb 07, 2019
Hi All,here is the Solution in German:1. öffne NVIDIA Systemsteuerung2. 3D-Einstellungen verwalten3. Bevorzugter Grafikprozessor: Integrierte Grafiken4. ÜbernehmenThe Problem: NVIDIA-Driver is not supported -> use internal GPU (e.g. Intel)

Likes

Translate

Translate
New Here ,
Feb 07, 2019 Feb 07, 2019

Copy link to clipboard

Copied

Hi All,

here is the Solution in German:

1. öffne NVIDIA Systemsteuerung

2. 3D-Einstellungen verwalten

3. Bevorzugter Grafikprozessor: Integrierte Grafiken

4. Übernehmen

The Problem: NVIDIA-Driver is not supported -> use internal GPU (e.g. Intel)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 11, 2019 Jun 11, 2019

Copy link to clipboard

Copied

This issue is driving me nuts.

Last week the solution from rayj249262 worked for me. Now when I started work this week it doesn't anymore. I truly don't understand why Reader doesn't recognize my proper GPU instead of just the internal one and even that is spotty. Please help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 24, 2019 Mar 24, 2019

Copy link to clipboard

Copied

Dears,

there is a solution that works with Adobe Reader DC

the problem is that Adobe Reader DC is not using your Dedicated GPU

to make it use it you have to follow the below steps

go to Edit>Prefrences>3D& muttimedia

make sure that preferred Renderer is DirectX 9

go to Edit>Prefrences>Security (Enhanced)

uncheck "Enable Protected Mode at startup"

uncheck "Enable Enhanced Security"

Restart the program and try it will now use Dedicated GPU and it will work Good

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 28, 2019 Mar 28, 2019

Copy link to clipboard

Copied

Hi Everyone,

Tried all the above settings none of them worked and then after some meddling inside the settings found a fix

1) In 3d and Multimedia options---> Tick on the box double sided rendering

2) In Preferred 3d pmi rendering mode---> Always render 3D PMI mode in front of model. (Instead of current...)

And you need to make sure you have your latest nvidia driver installed.

Hope this helps you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

1. Open NVIDIA Control Panel

2. Manage 3D settings

3. Preferred graphics processor: Integrated graphics

4. Apply

The Problem: NVIDIA-Driver is not supported -> use internal GPU (e.g. Intel)

This did not make any difference for me.  3D PDF's are slow and unusable now in Acrobat Reader.

Does Reader support GPU rendering?  Or is that only available in the Pro version?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 20, 2019 Aug 20, 2019

Copy link to clipboard

Copied

With our latest release on 13th Aug 2019 , the issue reported by you has been addressed.

If your product has not already been updated, to get the latest product update, click on the menu Help --> Check for updates in the product.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2020 Jun 08, 2020

Copy link to clipboard

Copied

Hi,

I have the slow rendering problem, on a new workstation system (2 months old):

Intel Xeon E-2144G/3.6 GHz
64GB DDR4-2666
PNY 5GB Quadro P2000

and SSD in RAID system

 

Tried all recommendations from the community, which I could find - but no improvement.

I cannot switch to internal graphics. There is only the nVidia Quadro card in it.

 

The system should be powerful more than enough. What can I do?

Please advise

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

Hi Bhavna,

unfortunately, this issue does not seem to be resolved.
The two possible workarounds (using integrated graphics card or disabling Protected Mode) are not applicable for use.
What can we do?

 

Stephan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 14, 2020 Dec 14, 2020

Copy link to clipboard

Copied

i have same problems

 

https://community.adobe.com/t5/acrobat-reader/3d-pdf-performance/td-p/10472716?page=1

 

seem to work always with Acrobat but only sometimes with Reader

none of the offered solutions are the real cause of this problem.We have new workstations with nvidia graphics and its working with Acrobat but not with Reader and we have older workstations with Nvidia and its working also with Reader. So it must be a problem inside Reader itself which may not always seems to work with newer hardware?

 

Changing security settings to have more performance is the wrong way. And why should the same security settings work in Acrobat but not in Reader.

 

This is ridiculous for a company like Adobe. No one is interested to get it solved. Buy Acrobat seems to be the only solution - good for Adobe, isnt it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2021 Jan 10, 2021

Copy link to clipboard

Copied

There is an uservoice action item open on Adobe uservoice page:

 

please vote for it to get that bug fixed:

 

https://acrobat.uservoice.com/forums/926812-acrobat-reader-for-windows-and-mac/suggestions/39755395-...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

is there a solution now it is August 2021? 

i have tried the above and didn't work on my Asus A15 laptop. rendering and slow and spotty. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

no solution yet, last message from adobe representative at end of july:

"The investigation took longer than expected and it came out to be a big engineering work item.
We are working to resolve the issue. Hopefully we'll be able to put it in production soon."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 25, 2021 Nov 25, 2021

Copy link to clipboard

Copied

Hi All, for me this discussion also applicable..
Poor that work stations do not perform for Reader.
Maybe a small consolation:
Modern software developers have no skills any more to make software with good and fast performance and robust functions.  They are only making more and more features. 
Who of us can remember the time when we had 386 and 486 computers with much less power, and despite that, we worked with faster graphics applications.....
Reader is not the only applications I use wich is only getting slower, while working on much faster workstations...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 25, 2021 Nov 25, 2021

Copy link to clipboard

Copied

LATEST
quote

Hi All, for me this discussion also applicable..
Poor that work stations do not perform for Reader.
Maybe a small consolation:
Modern software developers have no skills any more to make software with good and fast performance and robust functions.  They are only making more and more features. 
Who of us can remember the time when we had 386 and 486 computers with much less power, and despite that, we worked with faster graphics applications.....
Reader is not the only applications I use wich is only getting slower, while working on much faster workstations...


By @Mar219358765fe3

 

 

but this is not the case here, its a problem with certain hardware. Under Acrobat its working quite good so its either a lack of code together with the hardware or just a cheap try to sell licenses for Acrobat 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines