Fonts takes too long time to get installed

Explorer ,
Mar 16, 2019 Mar 16, 2019

Copy link to clipboard

Copied

Hi!! Adobe fonts are taking too long time to be installed! I guess this is an old issue, I used to have this same problem when this service was called as "Type Kit". I can see the problem continues, unfortunelly. My internet connection is Ok.

Views

28.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 25, 2021 Mar 25, 2021

Hi everyone – The Fonts team hears your frustration. While my reassurances aren't as valuable as offering a solution, please know we are actively working on determining the cause and treating this issue with top priority.

 

At this time, the best way to help the Adobe Fonts team fix activation issues is by posting your recent CoreSync logs from around the time you experience the delay, and let us know whether you are activating fonts in Creative Cloud Desktop or directly from the Adobe F

...

Likes

Translate

Translate
replies 102 Replies 102
New Here ,
Jan 15, 2022 Jan 15, 2022

Copy link to clipboard

Copied

Before Indesign there was Quark Xpress. Quark had the worst UX ever and lo and behold here we are today; Indesign is just like Quark. Simple stuff font management isn't working and the idea of working in the cloud is as janky as ever. This whole suite is a mess and I can't wait till there's another option I can spend my hard earned money on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 20, 2022 Apr 20, 2022

Copy link to clipboard

Copied

You could cut out the middle man and just go thru the process of downloading and activating fonts on your end and experience the issue first hand. Am I crazy for suggesting this, because it seems like this would be the most obvious first step towards fixing the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2022 Aug 24, 2022

Copy link to clipboard

Copied

Adobe doesn't give a flying F about user problems.
They've already got your money. They'll be getting it next month too.  My Indesign is currently in a background task loop the last 3 days trying to activate BRUSH SCRIPT if you can believe it.
You're terrible Molly, and so is the garbage company you 'work' for.
Shame on you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 16, 2021 Apr 16, 2021

Copy link to clipboard

Copied

April 2021 and the problem is still here. It's been over 20 minutes and this font still will not appear in my CC app or in Illustrator. It is beyond aggrivating and is a continual waste of time during my work day. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2021 May 19, 2021

Copy link to clipboard

Copied

May 2021 still a problem

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 20, 2021 May 20, 2021

Copy link to clipboard

Copied

May 2021 still a problem ... since 1 or 2 yeasrs.. please FIX THIS ! 

 

I don't see a point in telling you "when" the issue is happening.. being it the date and time or using the app or the website... because it's ALWAYS the case! ALWAYS since A LONG ASS TIME !! a few years ago, it worked perfectly!  i took like 2 seconds to activate any font... so it clearly is possible...  

 

Sometime it takes up to 20 minutes???? we work on timelines an sometimes its a matter of 15 minutes ! how are we gonna work like that ?  ( no even talking about fonts we use for a whole ass branding for a client, that then suddenly aren't available anymore... try explaining that to a client who has no money to then buy the font that was free when we chose it... for like 500$) 


on top of that, when indesign automatically tries to install the missing fonts... it doesn't work at all, and messes up the whole indesign because it's constantly loading and trying to install... an then there's no way around... i need to go install that font manually, an close the whole programm for that task to go away an indesign working "properly" again.... this is so ANNOYING an takes so much time!! 

GOSH i can't deal with this anymore .... fix it please...! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2021 May 25, 2021

Copy link to clipboard

Copied

yes!!! im experincing this issue currently SMH, stressing me out!!! DEADLINES!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

SAME HERE!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

This happened to me when I signed out of my adobe suite to use it on my home computer. Upon coming to work today, all my fonts were having to be reactifated?  [inappropriate language removed by moderator] Adobe. Honestly lost a morning already

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Guys, i found the fastest way to fix the font issue (temporarily) is by restarting the computer! yea this sounds stupid but works for me! so when you get frustrated try this out.

Hope they fix this soon, this really affecting my work so bad! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Same problem here, sometimes the font would never get activated with 5 min even more.

Really disappointed that this has not been fixed with two years passed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2021 May 27, 2021

Copy link to clipboard

Copied

Same issue.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 29, 2021 May 29, 2021

Copy link to clipboard

Copied

Just saw this thread. Yes, from time to time I have problems to get fonts activated from an application. What I do in that case is to go to fonts.adobe.com and activate the font manually. It's not as it should be, but it works. As this is, as it seams, only an intermittant problem, happening rarely, I never gave it a big thought. 

 

What I detected, however, was that my IT did effectively block some of Adobe's services and that caused a major disruption. Each time I evaded our firewall and proxy setup, It did work fine. As soon as my IT allowed all Adobe services to pass, I had olnly marginally troubles. So it is really worth to investigate if Adobe services are blocked. 

 

BTW: Don't trust your IT when they say they did not block Adobe services. If they aren't really part of the game, they may not know. A good starting point is here: https://helpx.adobe.com/in/x-productkb/policy-pricing/activation-network-issues.html

 

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

June 2021 and still having this issue. Makes me want to revert back to using a font management system such as Suitcase instead of Adobe. We pay a pretty significant subscription fee - you'd think Adobe would address this major issue. I can't wait hours (sometimes requiring a total restart of everything) for fonts to load.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Agreed! I came here for answers, and am immediately disheartened to hear that the problem is still universal. 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2021 Jul 11, 2021

Copy link to clipboard

Copied

I still have suitcase installed as a backup method to activate fonts - sad that I have to revert to that when my subscription for Adobe should cover all software working as intended. Ugh.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Me too. Not really sure why Adobe hasn't been able to solve this problem in over two years, though I have to confess it is fairly recent for me. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

Fr man this problem really stinks. I've found that manually activating fonts on the adobe fonts website works pretty well. It's less than ideal for sure, but it's better than sitting and waiting for 10 minutes. Really stupid that a huge company like Adobe can screw up and leave such a simple problem for people who's livelyhoods depend on their services. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2021 Jun 05, 2021

Copy link to clipboard

Copied

utterly ridiculous spending all the money we pay making sure nobody can crack the software more important than user experience

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

I'm here for the same problem. Tried to open a relatively recent document and all the fonts are deactivated. Why would they even be deactivated if I've used them within the past year? Why would they be deactivated at all? This is so obnoxious. I keep hitting activate fonts and I get the little spinning wheel of waiting time and then nothing happens. I have to hit it again. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

I'm just been hit with this the first time. I have a single, tiny tweak to make a document that was otherwise perfect and ready to go. Should have taken me less than a minute. Instead, I have to 'activate fonts' and I'm now half an hour in and nothing's happened and I'm stuck with a document that has 612 errors. This is the first time this has happened to me, so clearly Indesign can work without this. Please, Adobe, make it stop!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2021 Jul 10, 2021

Copy link to clipboard

Copied

Please see here: https://community.adobe.com/t5/adobe-fonts/fonts-takes-too-long-time-to-get-installed/m-p/11927267#M...

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

July 2021 and we still have the same problem. And the adobe lady just copy-paste the same answer 😞 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

The problem with this problem is: some users have it, some others not. I'm one of the lucky ones not being plagued with the trouble. But as a programmer, I know that problems that are appearing from time to time are difficult to fix. Especially that all these environments are diverse and there may be many causes.

 

The cause you could investigate first is if your IT does not block several needed Adobe nodes. And don't trust the IT when they say that they don't block. Ask them to check the Adobe public addresses. https://helpx.adobe.com/enterprise/kb/network-endpoints.html

 

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 07, 2021 Aug 07, 2021

Copy link to clipboard

Copied

Same issue here. It's been 20 minutes, and fonts are not loading. Here are my only two CoreSync files avaiable (attached).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Troubleshooting
Feedback & Suggestions
Fonts Licensing