Typekit is sooooooo slow

Explorer ,
May 08, 2019 May 08, 2019

Copy link to clipboard

Copied

Is anyone else having this issue? I was waiting nigh on 10 minutes for Typekit to activate one font. It was telling me it was activated in the browser, but no mention of it in the desktop menu app and eventually the small window popped up top right to say it was activated. Sorry Adobe, but that is a ridiculous length of time to activate one font. Have had this issue with various other fonts too. Puts me off using Typekit if this is how long it takes.

Is there any way of speeding it up?

Views

8.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2020 Sep 02, 2020

Copy link to clipboard

Copied

SAME. Hate it with a BURNING PASSION.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2020 Sep 02, 2020

Copy link to clipboard

Copied

Yes!!!!! Although I'd go further and say that its' sooooooooooooooooooooooo
sloooooooooooooooow.

--
*Anthony Behrens*
SwampThing Design + Photography

P: 027 4709829
E: anthony@swampthing.co.nz
20 Dorset Crescent
Palmerston North, 4410
New Zealand

*www.swampthing.co.nz *

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 04, 2020 Sep 04, 2020

Copy link to clipboard

Copied

Exactly. With the burnin passion of a thousand suns.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2020 May 26, 2020

Copy link to clipboard

Copied

I've found a work around to force fonts to update; open Creative Cloud, click the gear icon, go to services, and disable and enable Adobe Fonts. I also disabled and endabled syncing, so i'm not sure which one triggered it for sure.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2020 Jun 01, 2020

Copy link to clipboard

Copied

Hello, I've tried that and it still doesn't work... I remember it was never this bad. It really messes with my workflow when I'm trying to get Garamond and it takes forever! Also, the fact that Adobe can't keep me logged into their Creative Cloud or online website is really frustrating. Anyone else having logging in issues? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2020 Jun 02, 2020

Copy link to clipboard

Copied

I definitely get kicked out every now and then. About once every couple months.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Just want to update this proceedure, I've had it work for me multiple times. Click on your profile icon (blue circle thing upper right. Click preferences. Click on Services tab. Toggle Adobe Fonts off and back on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 05, 2020 Jun 05, 2020

Copy link to clipboard

Copied

Yes. Same issue here. Rather than getting work done I'm in this Adboe chat. It's rediculous. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2020 Jul 01, 2020

Copy link to clipboard

Copied

I’ve been waiting for fabulous FF Scala for half an hour to appear—this far.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 31, 2020 Jul 31, 2020

Copy link to clipboard

Copied

Yep...same here...zzzzzzzzzzzzzz...zzz

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 21, 2020 Sep 21, 2020

Copy link to clipboard

Copied

THINK I FOUND A FIX!

 

Make sure your adobe cloud app is up to date.

 

have had this same issue for months as well....noticed a comment here stating to go into the cloud app, click the gear icon and disable/enable adobe fonts -- but before I could do that I noticed I had an update to install to the cloud app. Updated, boom, my pending fonts loaded.

 

EVEN if this does work - Adobe, your customer support and bloatware is driving is all f*****g nuts.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 28, 2020 Sep 28, 2020

Copy link to clipboard

Copied

Hi, I'm with you on the bloatware issue. What am I paying $50 a month for...lots of headaches. I'm going to go see if I need to do yet another update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2020 Sep 29, 2020

Copy link to clipboard

Copied

Update. An up-to-date creative cloud app DOES NOT FIX IT.

 

Going on 30 minutes waiting for Montserrat Medium to activate via Typekit.

 

WTF ADOBE. WHAT ARE WE PAYING YOU FOR?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Experiencing Fits of Outrage because Typekit takes FOREVER to update the fonts to my photoshop...

WORKING LIKE THIS IS A    J O K E

 

FAAR FROM PROFESSIONAL, Adobe.....

When can we expect this problem to be solved?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

Just to echo everyone's comments here. Typekit is abysmal. Wasted 20 minutes of an already busy morning to activate one family of fonts (that still hasn't worked).

 

Plan B of downloading them and installing them locally will now become Plan A. Typekit simply does not function as intended.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

And to actually make matters worse, despite deactivating the fonts in Typekit, InDesign is still trying to activate one in background tasks so I can't get on with Share for Review because Montserrat Medium is still merrily turning itself over for ever and ever in the background. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 05, 2020 Nov 05, 2020

Copy link to clipboard

Copied

Oh dear, I found this thread after "updating" to CC from CS7 last week.

 

The whole way it handles fonts is so confusing, I have hundreds of fonts saved to my hard drive, but have been trying to active the official ones via CC job by job. I'm trying to a job which needs Montserrat, and I just can't start, as the fonts are still syncing 30 mins after I activated them. I try to upload my own version, but it won't let me as it's available with the the Adobe Fonts Library. I may have to go back to my ancient mac to get the job done.

 

I'm questioning my decision to use CC now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2020 Nov 13, 2020

Copy link to clipboard

Copied

It's awful and now they automatically deactivate fonts too. Totally distrupting my workflow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

Same issue. I now hit a wall every time I try to use this pretty basic feature of a service I pay a monthly fee for. Fonts I thought I had ready to go are randomly disabled. Anything new I want to experiment with ... yeah good luck with that. Half an hour later, I'm still waiting on two font families I need for a project.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

Is anyone else using Extensis Suitcase Fusion? I've come to realize when I activate a typekit font, it doesn't show in any of my apps for like 30 minutes (give or take, 20 minutes) .... but I recently discovered if I go through the typekit interface, go to the adobe fonts section, I see the typekit fonts are all there right away, set to 'permanent' activation. If I select them and disable them, and then set them to permanent again (toggle them on / off) they are immediately available in all the adobe cc apps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

I've worked in different computers, different operational systems, different versions of the CC, different accounts and this is always a problem, no exception. No links you send us will help if the problem is within the code/design of the creative cloud. We could have a buttom inside the Creative Cloud to "check for new fonts added" and force it to install. Right now we just need to sit and wait for several minutes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2021 Feb 24, 2021

Copy link to clipboard

Copied

Are there any real fixes to this problem yet? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2021 Mar 22, 2021

Copy link to clipboard

Copied

Nope. I'm currently waiting for fonts to install. Found this thread trying to figure out why. 

Adobe, can we get an answer, please?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Good to see I'm not the only one one this happens with. It usually takes a few minutes to activate a font, but de-activating can take anywhere from 15-45 minutes! Sometimes turning off the Typekit service and restarting Creative Cloud helps, sometimes not. Also when I turn Typekit on often it will just randomly re-activate fonts I had disabled days or months ago.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

Same here. This week my work was delayed every day because of this arrggg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines