• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Adobe XD says fonts are missing when they’re not?

Explorer ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Adobe XD says fonts are missing when they’re not, showing an orange exclamation mark icon (screenshot 1 below).

 

Also when I left click/control click on it, the contextual menu fails to provide a "replace font" option (screenshot 2)?

 

Even though the adobe helpx page says there should be a menu item called "replace fonts" there.

 

Thankfully so far this seems like a cosmetic annoyance more than anything that’s interefering with my work.

But it’s still super annoying. 

 

Anyone else getting this, and is there a fix?

 

Thanks.

 

1. Orange circle icon with exclamstion mark, indicating missing font (shows up even though font is there).

Screen Shot 2021-12-17 at 13.52.06.png

 

2. No menu item to "replace fonts" exist? Eveen though Adobe Help Desk page says it should?

Screen Shot 2021-12-17 at 14.02.26.png

 

3. Meanwhile the font is there and seems to be working just fine.

Screen Shot 2021-12-17 at 13.52.30.png

TOPICS
Known Issue , Missing feature

Views

947

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 12, 2022 Jan 12, 2022

Hi Neal Derek Lawson,

 

Thank you for your patience. Could you please try updating XD to the latest version (XD47)? 

 

Let us know if you still experience the issue.

 

We're here to help.

 

Thanks,

Harshika

Likes

Translate

Translate
Adobe Employee ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Hi there,

 

Thank you for reaching out and sorry for the trouble. It looks like you're experiencing the similar issue mentioned here: https://community.adobe.com/t5/adobe-xd-discussions/replace-fonts-window-disappears-replacing-fonts-....

 

If yes, then this is a known issue and the team is working on it. You will definitely see improvements in the future releases of XD.

 

Let me know if your issue is different. 

 

I will try my best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

No, my issue is a little different, because I'm not getting any "Replace font" menu item showing at all. 
Should the "Replace font" menu item always show? 
Or does the "Replace font" menu item not show when there are no actual fonts that need to be replaced? 
In my case XD is just showing me that a font is missing, when it's not missing and I can use it just fine, that's the problem.

XD is showing me that something's wrong when it's not. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

Hi Neal Derek Lawson,

 

Thank you for your patience. Could you please try updating XD to the latest version (XD47)? 

 

Let us know if you still experience the issue.

 

We're here to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2022 Jan 16, 2022

Copy link to clipboard

Copied

Hi Harshika.

 

I am having the excact same problem and the update (XD47) didn't help.. any suggestions?

 

Thanks,

Ortal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

Hi ortala38508568,

 

We are sorry for the trouble. Would you mind telling us if it's happening on a specific document? Please share the screenshot of your About XD info page from Help menu.

 

Have you tried signing out of XD and Creative Cloud desktop, restart the machine, and then launch XD from Creative Cloud desktop app?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

Hello,

Thank you for contacting me
I have tried all your suggestions - including removing XD and re-install,
installing older versions, logout- login...same issue every time.
all fonts exist on the computer but the program writes that they are
missing. it happen with all fonts (including system fonts) and in every
file.
the font display in the design, by the way, is the right one 🙃
it looks like a technical problem in the assets panel

see attached screenshots
[image: image.png]
[image: image.png]

Best,
Ortal

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Thanks for trying the steps suggested. Could you please also confirm if these fonts are visible in any other Adobe products like Illustrator, InDesign, Photoshop? Please also share the location where all the fonts are installed in your machine.

 

We will try our best to help.

 

Thanks,

Harshika

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

All other adobe CC products are syncing great with the fonts except adobe
XD. I have also tried to activate some fonts from the adobe library but
still had the same issue.
All of my fonts are installed in the system fonts folder

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 20, 2022 Jan 20, 2022

Copy link to clipboard

Copied

Thanks for the confirmation, ortala38508568.  We would request you to please try enabling the windows cache services.

Steps-

  1. Windows + R (RUN)
  2. Services.msc
  3. Hit Enter
  4. Scroll down to 'Windows Font Cache Serive'
  5. Right click on it and Click 'Restart'

 

Screenhot below-

HARSHIKA_VERMA_1-1642694697550.png

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 04, 2022 Feb 04, 2022

Copy link to clipboard

Copied

Sorry to hear that. I hope you're doing well now.

 

Thank you for sharing the logs, ortala38508568. I am unable to download the XD file and full crash dump at my end. Please save the XD file in your machine and upload them to a shared location such as CC or Dropbox/ WeTransfer and share the URL with me over a private message.

 

Note: Please share the link to the community post over a PM for reference.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2022 Oct 17, 2022

Copy link to clipboard

Copied

LATEST

Not sure if this will help anyone else, but after having the same issue, but also having issues with the "Publish as Library" button disabled, I followed the accepted answer on this issue and it fixed the font issue for me too:

https://community.adobe.com/t5/adobe-xd-discussions/xd-publish-as-library-button-disabled/m-p/121821...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines