Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


[Crash/Load]-Massive performance problems (because of component use) with XD

Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Hello everyone,

Since I use the new components feature (I really love it!), the XD performance is going down with any new element I add or use in the design.
Now it has reached a point, where I can't do anything without crashing the whole programm. It even crashes, when I just want to save it offline.

 

Hardware:

I’m using a MacBook Pro 2018, 2,9 GHz 6-Core Intel Core i9, with 32 GB DDR4, and a Radeon Pro 560X 4GB graphic card.

That really should be enough for everything.

 

I’m working on a big app project with round about 150 screens that I have placed all on my canvas – together with my components collections.

 

At the moment I’m struggling with:

– File opening times of 2-5 min

– Auto save time (Cloud) of 1-5 min

– Crash of XD, now basically after any action

 

Working is unfortunately not possible that way!

 

The main problems (that all play together) are:

– Cloud auto-save, that makes working hell because of the long loading times

– Main components (e. g. the footer bar, header bar, accordions, that are on nearly any screen), including a lot of „inactive“ components, icons and setting, to be flexible in changing in the screens

– Repeat grid with large components are a direct XD crash, when I ungroup them

 

What makes it a little bit better (… but can't be the long term solution):

– Using a smaller window size for XD

– Working off-Cloud

– Using a separate file to group and build the screens and later paste them in the main layout (works until paste into the main file 😉 )

 

Is there anything else I can do be able to work again?

Thanks in advance for your help!

TOPICS
Product performance

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 04, 2020 Aug 04, 2020
Hi Kristopher and Marc, I am sorry for the delay in response. I would like to confirm if your issue is resolved in the latest version of XD 31.2. Please feel free to update the discussion and let me know if you need further assistance on the issue. I will try my best to help. Thanks, Harshika

Likes

Translate

Translate
Community Beginner ,
Apr 18, 2020 Apr 18, 2020

Copy link to clipboard

Copied

Hi Harshika, 

What's the status with this issue?

I have the same issues that is mentioned by the other users above.
Have your XD team come up with a solution on this yet? 

System: Windows 10

Thanks,
Kristophpher

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 04, 2020 Aug 04, 2020

Copy link to clipboard

Copied

Hi Kristopher and Marc,

 

I am sorry for the delay in response. I would like to confirm if your issue is resolved in the latest version of XD 31.2.

 

Please feel free to update the discussion and let me know if you need further assistance on the issue. I will try my best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 06, 2019 Dec 06, 2019

Copy link to clipboard

Copied

It would also help if you could share a video reproducing the issue as also share the XD file with Harshika.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

I don't understand how this thread is marked as solved. The "Correct Answer" is not an answer at all, it's just a link to contact support. What's going on here?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

LATEST

Hi there,

 

It looks like someone has accidentally marked it as correct long ago. I have unmarked and marked the other one as correct because as far as the issue is concerned it was fixed with XD 31.2 version. Are you still experiencing the issue with XD 37.1 version?

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2