[Import & Export]-Adobe XD doesn't parse SVG path correctly

New Here ,
Mar 11, 2020 Mar 11, 2020

Copy link to clipboard

Copied

What happens:

When trying to insert the attached SVG into Adobe XD, only the first part of the path is inserted, everything after that is cut off.

What should happen:

The full path should be displayed, like in the browser (e.g. Chrome).

 

The SVG is from https://www.carbondesignsystem.com/guidelines/icons/library/ (Search for "Collaborate"). Other icons from that library work fine.

Interestingly the same thing happens when trying to optimize the SVG here: https://petercollingridge.appspot.com/svg-editor/.

As a workaround, I've been able to load the file after importing and exporting it from https://editor.method.ac/.

 

 

<The Title was renamed by moderator>

TOPICS
Import and export , Product performance

Views

2.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 17, 2020 Mar 17, 2020

Hi there,

 

We are sorry for the delay in response. There are few unsupported features of SVG file into XD. Please check out this article: https://helpx.adobe.com/in/xd/kb/import-export-issues.html 

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate
Adobe Employee ,
Mar 17, 2020 Mar 17, 2020

Copy link to clipboard

Copied

Hi there,

 

We are sorry for the delay in response. There are few unsupported features of SVG file into XD. Please check out this article: https://helpx.adobe.com/in/xd/kb/import-export-issues.html 

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 27, 2020 Mar 27, 2020

Copy link to clipboard

Copied

Thanks for the information 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 01, 2020 Apr 01, 2020

Copy link to clipboard

Copied

You are welcome. Please feel free to reach out to us in the future for any query related to XD. We'd be happy to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2021 Dec 29, 2021

Copy link to clipboard

Copied

LATEST

Something similar here 🙋🏼‍:male_sign:

 

So I am using Adobe XD to create software prototypes and stuff. I designed an icon in it and in the export stage, I am facing a weird problem. This is the icon, when exported as PNG, which exports as is (true to the design) -  

MrittickChoudhury_0-1640788764945.png

 

However, this is what happens when exported as SVG (tried all permutations and combinations of the SVG export parameters, still same results) - 

MrittickChoudhury_1-1640788764912.png

 

Notice how the lower-left portion of the icon-design is completely messed-up? That's the bug. 

Similar problems are showing-up while exporting other SVGs as well, which is forcing us to export them inn PNG, but it's not the ideal scenario and hampers us from using lottie-animations, which is a dealbreaker for our product. 

 

Kindly requesting for some support and a fix please. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines