.exr sequence fills up ram completely and crashes after effects + media encoder

Community Beginner ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

When opening a composition with an .exr image sequence, after effects immediately begings loading the composition to the ram preview. (without pressing play) You can see the green ram preview growing, and there's no way to stop this. This then maxes out completely (my system has 64gb of ram) and does not clear itself. 

 

The same issue occurs with using media encoder to render the composition, as the render progresses, the ram is slowly used up until the headless after effects.exe crashes, leaving media encoder frozen midway through the render. You have to force close the application then. On some renders it will make it all the way through without crashing. 

 

TOPICS
Bug , Crash , Error

Views

390

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Sep 13, 2021 Sep 13, 2021

Are you on build 22.0x94 or above? The is a memory leak we just fixed in x94 that should help with this.

Likes

Translate

Translate
Adobe Employee ,
Sep 12, 2021 Sep 12, 2021

Copy link to clipboard

Copied

Hi,
Automatic rendering of composition when the app is idle, is a new feature called 'Cache Frames When Idle' (Speculative Preview). When you start editing in After Effects, it should stop immediately.

You can read more about it here - https://community.adobe.com/t5/after-effects-beta-discussions/speculative-preview-now-available-in-1...

You can turn this feature on/off here: Composition Menu -> Preview -> Cache Frames When Idle. And you can modify the idle delay and other settings for this feature in Preferences Dialog -> Previews.

The crash that you are seeing with Media Encoder seems like a different issue. Can you share more details on it.

-Vinayak

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Media encoder will be rendering along and then all CPU/GPU usage will drop and opening task manager shows that the AE process inside media encoder is gone, leaving just media encoder. I'm not sure if these issues are connected but the reason I felt that they are is that BOTH crashes result from after effects using 99% of available RAM compared to the allotted 80% that the previous version used. Both versions are set to use the same amount of ram. If i go to purge > all memory, AE will hang for maybe 10 seconds and then clear the memory but IMMEDIATLY start rendering more cache files until the memory is used up and the program becomes unstable. I will check the idle times for that setting but it seems to be working strangely. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Are you on build 22.0x94 or above? The is a memory leak we just fixed in x94 that should help with this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

LATEST

This seems to have solved the problem. Thanks guys!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources