Exporting Animation with shadow layer transparency

Explorer ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

I did not realize while building out my animation that a layer's opacity property was only an author tool and would not render/export out the same way. As soon as I bring the SWF or MOV file into After Effects, my shadow layers are back to 100% opacity. 

I've seen some solutions mentioning movie clips, but this is a traditional style animation where every key frame and inbetween is drawn, so I'm not sure if that process would work. So far I haven't gotten it to work properly with my keyframes.

Does anyone know another solution to this? It seems kind of ridiculous if Animate does not have the capability to export layers at a lower opacity. 

TOPICS
How to , Import and export , Missing feature , Performance

Views

125

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Enthusiast , Sep 14, 2021 Sep 14, 2021
Thanks, I just checked the file but I couldn't see a problem on my end. I noticed that you lowered the fill alpha of every frame in the shadow layer to 50% while not the fastest method just exporting it as is gave me an accurate SWF, I didn't have to change a thing. Just for the sake of testing I restored all the fills of the shadow layers to 100% alpha and converted these layers to symbol using the convert layer to symbol option:Then I just lowered the Alpha value of the resulting nested symbol...

Likes

Translate

Translate
Enthusiast , Sep 14, 2021 Sep 14, 2021
Ah it's because you're converting it into a Movie Clip symbol; forgot to say it has to be a Graphic symbol.Movie Clips are for developers, they don't play on stage, Graphics do. For purely animation purposes remember to use Graphic symbols only.

Likes

Translate

Translate
Enthusiast ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi, converting the layer into a symbol should work regardless if it's frame animated or not. Here's how to do it:

Select your "shadow" layer > right click > Convert Layers to symbol.

Once done go to the properties panel (object tab) and select Alpha under Color Effects to lower the oppacity.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Appreciate your swift response, Marco!

Do you know if it's possible to do this with masked layers?  When I use that same method for the masked layers, I lose everything:

Screen Shot 2021-09-13 at 8.39.38 PM.pngScreen Shot 2021-09-13 at 8.41.24 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Yes you can, you just have to select both the mask and the masked layers before running the command. Select "ball1_copy" and "Shadows" then convert them to symbol.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Hi Mario,

Thank you again for your response and help!

Sorry, I should have specified that I did have both layer selected before running the command. I know it doesn't appear that way in the images I posted.

I've gotten it to play a preview when I click on it within the Library Panel, but nothing is showing on  the stage.

Screen Shot 2021-09-14 at 1.26.39 PM.pngScreen Shot 2021-09-14 at 1.28.47 PM.png

I tried it in another scene as well. I can't get it to play a preview and still completely lose the mask/shadow.

Screen Shot 2021-09-14 at 1.34.42 PM.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

That can't be right, perhaps you left a duplicate layer on stage.

- In the second screenshot nothing is going to appear in frame 1 since the first 6 frames of layer "ball1_copy" are empty.

- In the third screenshot you have a layer called "Ball_1", what is the purpose of this layer? Is this a duplicate of  "ball1_copy"? If so hide it or remove it.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Yes, I scrubbed through the whole animation because there were blank frames at the beginning of the timeline, but nothing shows up throughout the whole animation.

In the third screenshot, the layer called “Ball_1” is the actual animation. The “ball1_copy” layer is the mask for the shadow layer. I selected the ball1_copy and shadow layers and converted them into a symbol. That’s when they disappear.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

I see, are you able to share the FLA file using a sharing service like Google DriveWeTransfer or Wormhole? I'm convinced this is an easy fix but it's difficult to know for sure with only screenshots.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Yes, absolutely! Here is a link to the file: https://we.tl/t-sJaxcrAf0W 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Thanks, I just checked the file but I couldn't see a problem on my end. I noticed that you lowered the fill alpha of every frame in the shadow layer to 50% 

Mario_CR_0-1631660000581.png

while not the fastest method just exporting it as is gave me an accurate SWF, I didn't have to change a thing.

 

Just for the sake of testing I restored all the fills of the shadow layers to 100% alpha and converted these layers to symbol using the convert layer to symbol option:

Mario_CR_5-1631661559586.png

Then I just lowered the Alpha value of the resulting nested symbol and it gave me the same effect, the SWF was accurate as well.

Mario_CR_4-1631661298718.png

Here's the modified file along with the SWF: https://we.tl/t-8dmXu1CiGF

Take a look and let me know if you're still having issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

This is so strange - I'm doing exactly what you've described, but I still lose the shadows.

Here's a screen recording:

 https://youtu.be/ohzPVBvHLV0

 

However, I'd forgotten that I had gone through and changed the fill alpha of every frame in scene - I guess that is the solution when not using symbols. I just tried it on the other scene and it worked for exporting both the SWF and mp4.

 

Thank you for all of your help!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

Ah it's because you're converting it into a Movie Clip symbol; forgot to say it has to be a Graphic symbol.

Movie Clips are for developers, they don't play on stage, Graphics do. For purely animation purposes remember to use Graphic symbols only.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

LATEST

Thank you for the clarification! I got confused after reading about how using movie clips could be the solution for opacity issues. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines