Html5Canvas

New Here ,
Jan 01, 2017 Jan 01, 2017

Copy link to clipboard

Copied

hi ,

    i am using adobe animate cc ..i have problem in using html5canvas while publish in html some times its not working properly and when i use images in file its not working in chrome and internet explorer , i missing something i dont  know what am missing ,Html5canvas file is not working in offline its working only when have internet connection  ...can u pls anyone help ..

  Thanks in advance .

[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

[Moved from Comments forum to specific Program forum... Mod]

Views

4.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 02, 2017 Jan 02, 2017
You should have been opening the developer console in Chrome to see if there are any error messages.Go into your publish settings and disable spritesheets, if it's still enabled.

Likes

Translate

Translate
Adobe Community Professional ,
Jan 01, 2017 Jan 01, 2017

Copy link to clipboard

Copied

is it working in any browser?

have your uploaded your files to a server?  if so, what's the url to your html page?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2017 Jan 02, 2017

Copy link to clipboard

Copied

hi ...its working fine in firefox and latest internet explorer ,but it is not working in chrome ,when i replace with vector instead of images then its working ..i cant control through code while opened in chrome browser ..i attached a link of my files  ,plz help ..thanks in advance .. Dropbox - JS.rar

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 01, 2017 Jan 01, 2017

Copy link to clipboard

Copied

"Html5canvas file is not working in offline its working only when have internet connection"

This is probably because by default, your published files will reference the CDN-hosted versions of the CreateJS libraries, which requires an internet connection.

In Publish Settings > Advanced, you can uncheck "Hosted Libraries" to publish a copy locally and reference that instead.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2017 Jan 02, 2017

Copy link to clipboard

Copied

thank you for your reply.....no its not working ..if i dont have a internet connection while publishing its showing blank page  in browser...plz help thanks in advance

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 02, 2017 Jan 02, 2017

Copy link to clipboard

Copied

click file>publish settings>advanced>untick 'hosted libraries' as suggested in message 2.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

LATEST

We are having the same issues (April 2022) and this did not solve the problem. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2017 Jan 02, 2017

Copy link to clipboard

Copied

And also when i import a image in stage and convert to movieclip and add event to a moviclip , and published means not working in chrome ,but working in firefox ...i dont know what to do ..plz help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 02, 2017 Jan 02, 2017

Copy link to clipboard

Copied

You should have been opening the developer console in Chrome to see if there are any error messages.

Go into your publish settings and disable spritesheets, if it's still enabled.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

In developer console its showing error ..."Uncaught An error has occurred. This is most likely due to security restrictions on reading canvas pixel data with local or cross-domain images." can u say the solution for this problem ...thanks in advance

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

The solutions have already been given.  Go to File > Publish Settings > Sprite Sheets, and uncheck "Combine image assets into sprite sheets".

For your other issue where things aren't working without an internet connection, in File > Publish Settings > Advanced, uncheck "Hosted Libraries".

Then save and re-publish.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

i did everything which you said ..but its not code working in chrome ...showing above error ..shall i send a file ..can u check it

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

Sure, share your file.  The previous file you shared on Dropbox did not have the correct publish settings.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

Dropbox - work.rar ..this file works fine in firefox ,but in chrome and internet explorer is not working ,In chrome file viewing in IE not viewing also ..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 03, 2017 Jan 03, 2017

Copy link to clipboard

Copied

So in addition to the other two issues, it's also this:

Error about cross-domain images · Issue #726 · CreateJS/EaselJS · GitHub

canvas - createjs button in flash is not working - Stack Overflow

html5 - EaselJs errors in chrome - Stack Overflow

For your click events, creating invisible buttons on separate layers instead of directly targeting the movieclips with images in them should fix the local viewing issues in Chrome. 

Otherwise, it should be fine when uploaded to a server either way.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 13, 2017 Mar 13, 2017

Copy link to clipboard

Copied

Hi there,

You´re right, I had the same problem parsing an XML from Adobe AnimateCC 2017 version 16.0.0.112.

The error on console is "Uncaught An error has occurred. This is most likely due to security restrictions on reading canvas pixel data with local or cross-domain images."

Althought you can think it has to be with images of domains, I think It has to be with mouse events, once I used and invisible button (as in the Flash old times!) it disappeared. I didn´t have to change any Chrome Security settings

Regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines