• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Audition will not record until audio is passed through the speakers first

Explorer ,
May 27, 2024 May 27, 2024

Copy link to clipboard

Copied

Audition 24.4.1.3

Windows 11 - 23H2

Intel 13980HX

64GB Ram

 

This isn't likely an Audition problem, but I'm hoping maybe someone has some insights to share here.


Our team got 5 new Asus ProArt laptops (H7604JI). On every single one of them, if you start a recording in Audition, the playhead will stutter along, jumping up the timeline every second or so, but nothing will be recorded. But as soon as you pass some audio through the speakers, Audition will record perfectly fine. 

 

It doesn't even have to be an audio file. If you just drag the volume slider on the Windows taskbar so you get the Windows "ping" sound, then that's enough.

 

I have tried changing the recording settings, tried the internal microphone as well as a USB mic (Shure MV7) and got the same results.

 

You can see the issue in the attached video. I didn't include the microphone recording in OBS so that there was sure to be no conflict, but you'll see the playhead stutter, then hear the windows system sound, then see me say "test, test, test, test".

Views

115

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 27, 2024 May 27, 2024

Copy link to clipboard

Copied

This is going to be related to your sound device. I'm a lttle worried about your system sounds being audible - that's very much a no-no when it comes to using an internal sound device (and it's in the Audition installation instructions...) Initially try setting these to 'no sounds', which should stop the OS from forcing the sample rate to what it wants, rather than what you want. It could easily be just this causing the issue!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 28, 2024 May 28, 2024

Copy link to clipboard

Copied

Thanks for the reply Steve. I'll admit that Audio (and by extension Audition) is not my forte, so please excuse my ignorance.

 

You mention Audition installation instructions. Honestly I didn't even know such a thing existed beyond "click the install button in the Creative Cloud app". Searching for these instructions brought me to this page and then to this page, but none of the links I clicked through mentioned disabling system sounds (or how to do so). In the sound control panel I did change the sound scheme to "No Sounds" but this didn't change Audition's behaviour, so I'm not sure if this is what you meant. The other instructions at those links for setting up audio hardware correctly are steps we've done before, so that bit wasn't foreign to me.

Just to be clear though, we don't ever use the internal mic on the laptop to record, we always use an external mic. In this case the Shure MV7 mentioned previously. However this issue persists regardless of microphone used. The same mic works without issue on our stationary workstations, and I've never experience this kind of "bug" with previous workstations or laptops we've used. We've never had to disable system sounds in Windows (and haven't done so on the stationary workstations) to get Audition to record properly either (not arguing against it, just explaining my ignorance in this case).


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 29, 2024 May 29, 2024

Copy link to clipboard

Copied

LATEST

Okay, I'll explain the background:

 

Having re-read all of the installation requirements, it seems that they've dropped this piece of advice. I think I know why, though. They are only providing instructions that apply to what they regard as a 'correct' installation, ie one that uses a sound device that can use an ASIO driver; this is because Audition uses an ASIO engine. No internal sound devices have ASIO drivers - they all rely on Microsoft's MME and WASAPI drivers, and that's where the system sounds problem stems from. ASIO has much lower latency, as it bypasses most of the layers of OS before it gets to the hardware. Which is fine if you have an external device with the correct driver, but not everybody does (despite it being a Very Good Idea...)

 

The trouble with MME certainly used to be that you could be quite happily using Audition when along came a system sound which, having priority, would suddenly switch your device's sample rate to a much lower one. This could easily cause chaos, and it did. What I suspect happens now is that all such requests get passed through a Microsoft resampler so that the device rate doesn't have to change. All attempts by M$ to create a decent one have failed so far - there is a noticeable quality drop when this happens.

 

Other things: it occurs to me that your issue might be that the Windows settings on your sound device might be set by default to whatever the system sound rate is, rather than the rate you are trying to record at, and that playing an external sound is giving it a kick in the right direction. If you right-click on the Speaker icon on the task bar and select Open Sound Settings, you can get to the Sound Control Panel. Highlight your device and go to Properties, and then Advanced settings, and select in the Default Format the bit rate and depth you are trying to use. Also put a check in the two boxes at the bottom regarding exclusive control. Okay all of that, possibly restart everything, and try again... No I have no idea why they hide this away so comprehensively!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines