• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Bridge Workflow Panel with Batch Rename and String Substitution not works

Contributor ,
Jan 11, 2023 Jan 11, 2023

Copy link to clipboard

Copied

I make a Bridge Workflow with the new Workflow Panel. I use as first step a Batch Rename and in Batch Rename, I use a String Substitution. The String Substitution is the issue. When I use it, the Workflow does not work. I receive an error: Filename is not unique.
Workaround: I must also insert a Sequence number in the Batch Rename, then works.
But I would the exact same name as the original with only my String Substitution not with an extra sequence number.
Maybe it is a bug?

 

Adobe Bridge: 13.0.2.636
Windows 11

TOPICS
Problem or error

Views

411

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 18, 2023 Jan 18, 2023

Copy link to clipboard

Copied

Hi @Dimizu ,

 

Can you please try and save your batch rename preset before starting the workflow.
It will pick up the last saved or default preset settings if you don't save the preset.

Screenshot 2023-01-19 at 11.13.23 AM.png

Please let me know if that resolves your issue.

 

Thanks

Shubham Verma

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

I think that “Save Preset” is the problem. I choose an existing Preset Name (already saved). But the Alert "Edit Presets Must be Saved" remains.

So I click to Save Button, I insert a new name for the Preset. Now I see the new name but the alert "Edit Presets Must be Saved" remains.

I am unable to get rid of the alert no matter how and where I save.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

Hi @Dimizu ,

Please save the preset after the modification is done. If you still faces the issue, please share video recording/ screenshot of the workflow you are using. So that we can narrow down the issue at our end as well.

 

Thanks

Shubham Verma

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

Hi @Dimizu ,

After saving the preset,  "Edit Presets Must be Saved" will be in disabled state. When you made a modification it will be enabled.
When preset is modified:
ModifiedPreset.png

When preset is in saved state :
SavedPreset.png
Please let me know if that resolves your issue.
Thanks
Shubham Verma


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

Yes this is correct, but this not solve the problem. When I make a modifikation then "Edited Presets Mus be Saved" will be in active state. Then I Save the preset and the alert "Edit Presets Must be Saved" is already there but in inaktiv state. I don't know if this is normal. If it is then ok. But the problem is not this, the problem ist this:

I make a Bridge Workflow with the new Workflow Panel. I use as first step a Batch Rename and in Batch Rename, I use a String Substitution. The String Substitution is the issue. When I use it, the Workflow does not work. I receive an error: Filename is not unique.
Workaround: I must also insert a Sequence number in the Batch Rename, then works.
But I would the exact same name as the original with only my String Substitution not with an extra sequence number.

Now with the video you can also see the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

Hi @Dimizu ,

As i can see in the recorded video, the file on which you are trying to run workflow with batch rename, dont have any string matching with your substitution string conditions.
File should contain a certain string to be substituted.
Can you please try and add a string substitution row with string that is present in your filename.
Thanks,

Shubham Verma

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

LATEST

Yes, I can confirm, that this is the problem. When the file does not have a string that is matching with my substitution then I get the error.
But I need all this string substitutions. It is crucial that the string substitution works also with an not matching filename. With the normal batch rename function it works perfectly. Only in the context of Workflows is a problem. So, I hope you can fix this in further updates.

Thanks 
Dietmar

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines