• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Looking for a version of Adobe Bridge for Mac OS 10.11.6

New Here ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

I have an old Mac (OS 10.11.6), current versions require a minimum OS of 10.15.X.  Is there a legacy version that can be loaded onto this older comp

TOPICS
Download and install

Views

69

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

https://helpx.adobe.com/bridge/system-requirements/earlier-versions.html

https://prodesigntools.com/

You'll have to check system requirements and see if ProDesignTools has a direct download link for a compatible older version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

LATEST

Be aware that OS X 10.11 is no longer supported and not getting security fixes. Its not safe to use online.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines