• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Skip to slide 1

Explorer ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

I have Captivate 2019 version 11.5.5.678.   I have a button on the last slide that says restart presentation.  Here is my action:

 

lmaley_0-1631193025859.png

It does not work.   All it does is replay the slide.  I had this working (in a different presentation) before I updated to Big Sur, but now I cannot get this to work.    I looked through the internet and tried what i found:

 

lmaley_1-1631193101148.png

Branch aware is unchecked.

Allow backward  movement is checked.  Why is this not working?

Views

56

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Sep 16, 2021 Sep 16, 2021

Rod helped me figure out what is going on here.   

 

It’s due to the way you have set up the Advanced Actions that are executed ON Slide Enter of each slide.  This is what he said:

 

You’re using these Advanced Actions to set the value of a tracking variable called vstart to the value of cpInfoCurrentFrame at the beginning of each slide.  This enables you to have a button on each slide to just replay the slide.

 

However, when you click the button on the final slide to jump back to Slide 1 this causes

...

Likes

Translate

Translate
Community Expert ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Where is the Results slide? What are the actions in Quiz Preferences, Pass or Fail? Normally I would expect one of those to get back to the start of the presentation. How did you set up Reporting? How many attempts do you provide on quiz level? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

In this presentation, I have no quizzes, it is informtion only.  So no results slide.  Here are my quiz preferences though.

 

lmaley_0-1631197295447.png

lmaley_1-1631197335840.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Why did you post screenshots of Quiz settings if you don't have a quiz? Confusing!

Do you have Pretest slides? They also will prevent navigation?

I cannot imagine another reason, unless you have some advanced actions on the first slide?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

I was just grasping at straws at why this was not working.  

This was what I found as fixes and I could not find anything else as a fix.   I have no idea of why this is not working.  I have done this many tiimes before.   I am going to try it on a mac that is not updated to Big Sur and see if it works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Publishing it with a Catalina system did not work.   this was the first one I tried after upgrading to Big Sur.  Any ideas of why it is not working?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

I am a Windows only user, if this is something specific for Mac, cannot help you. Sorry.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

LATEST

Rod helped me figure out what is going on here.   

 

It’s due to the way you have set up the Advanced Actions that are executed ON Slide Enter of each slide.  This is what he said:

 

You’re using these Advanced Actions to set the value of a tracking variable called vstart to the value of cpInfoCurrentFrame at the beginning of each slide.  This enables you to have a button on each slide to just replay the slide.

 

However, when you click the button on the final slide to jump back to Slide 1 this causes a problem.  Clicking the button to Restart the project DOES actually jump the user back to the first slide.  But on that first slide there is also an Advanced Action that is set to immediately jump to whatever frame vstart is currently set to. 

 

Since vstart was last set to the value of the first frame of the final slide, that’s where the action jumps the user.

 

So, in the blink of an eye, the user has been jumped from the final slide back to the first slide and then back to the final slide again.  It happens so quickly that you cannot notice.  It just looks like you jumped back to the beginning of the final slide.  The button actually DID do as it was programmed to do, jump to Slide 1.

 

So to resolve the issue, you need to adjust the Advanced Action being executed on the very first slide so that it does not jump the user to the vstart frame.  I would suggest you just take out that line of the action.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines