Highlighted

Captivate 9 crashes right after (re-)installation

New Here ,
Jun 04, 2018

Copy link to clipboard

Copied

We have trouble after installing Captivate 9. The installation finishes but if you start up the application "an error has occurred. Captivate needs to close". You don't have the chance to edit the preferences and change to a local path, it just crashes. Windows 10 v1607 build 14393.2248. Older installations that used to work have the same problem, it seems to relate to Windows updates. Completely removing and re-install gives the same problem. Some Adobe help is needed here..

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Maybe you misunderstand: this is a user forum

DId you clean the Preferences when (re)-installing? You don't need to open Captivate, just look in the subfolder 'utils' under the application folder and run the ClearnPreferences.... appropriate for your OS. If you are on Windows, do Run Captivate as Admininstrator, please.

Views

252

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Captivate 9 crashes right after (re-)installation

New Here ,
Jun 04, 2018

Copy link to clipboard

Copied

We have trouble after installing Captivate 9. The installation finishes but if you start up the application "an error has occurred. Captivate needs to close". You don't have the chance to edit the preferences and change to a local path, it just crashes. Windows 10 v1607 build 14393.2248. Older installations that used to work have the same problem, it seems to relate to Windows updates. Completely removing and re-install gives the same problem. Some Adobe help is needed here..

Most Valuable Participant
Correct answer by Lilybiri | Most Valuable Participant

Maybe you misunderstand: this is a user forum

DId you clean the Preferences when (re)-installing? You don't need to open Captivate, just look in the subfolder 'utils' under the application folder and run the ClearnPreferences.... appropriate for your OS. If you are on Windows, do Run Captivate as Admininstrator, please.

Views

253

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 04, 2018 0
Most Valuable Participant ,
Jun 04, 2018

Copy link to clipboard

Copied

Maybe you misunderstand: this is a user forum

DId you clean the Preferences when (re)-installing? You don't need to open Captivate, just look in the subfolder 'utils' under the application folder and run the ClearnPreferences.... appropriate for your OS. If you are on Windows, do Run Captivate as Admininstrator, please.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 04, 2018 0
New Here ,
Jun 08, 2018

Copy link to clipboard

Copied

Thanks for the reply. It was solved with the CleanPrerencesWin.bat and then run the application as administrator, going to Help.. and from there "Updates". After getting Update2 and some other, starting Captivate normally was ok. Then immediately changed the paths in Preferences to a local path.
After this only "Video Demo" still gave an error, something with "COM Surrogate"..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 08, 2018 0
New Here ,
Oct 16, 2018

Copy link to clipboard

Copied

Hello,

Currently we're experiencing the issue also with users on win 10 build 1709. that captivate 9 crashes without being able to set the preferences due to the redirection. Even though the CleanPrerencesWin.bat file is tried and the folder got renamed under *\username\appdata\local\adobe\captivate and *\username\appdata\roaming\adobe\captivate.

The program crashes as soon as the dialog box is closed to change the folders under preferences.

Under a user without redirections this is not an issue.

But every other user is. Is there a way to change the preferences mapping without starting the program? Registry or ini file or...?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2018 0
Adobe Community Professional ,
Oct 16, 2018

Copy link to clipboard

Copied

Not that I am aware.  However, perhaps we need to look at a few other possible causes first.

  • Are you launching Captivate with Run As Administrator privileges?
  • Are you on a corporate network using roaming user profiles?
  • When you look in Preferences at the Default Location fields, are they both pointing to folders on the local C drive of your PC or somewhere else?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2018 0
New Here ,
Oct 16, 2018

Copy link to clipboard

Copied

Hello,

Thank you for the quick reply.

  • Are you launching Captivate with Run As Administrator privileges? Yes, but with or without same result. Unless run under a different user account with admin privileges since then the redirect is not found/applied.
  • Are you on a corporate network using roaming user profiles? Yes
  • When you look in Preferences at the Default Location fields, are they both pointing to folders on the local C drive of your PC or somewhere else? Cannot get to this setting under the users profile as it crashes as soon as close is clicked on the message that the preferences need to be changed, and until this point nothing can get accessed without closing the dialog boxes first.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2018 0
Adobe Community Professional ,
Oct 16, 2018

Copy link to clipboard

Copied

I would suggest your setup is the cause of your problem.  Captivate is not designed to be installed with roaming user profiles and the fact that some kind of redirect is occurring right after launch is tripping up the app.

You will definitely need to be running Captivate with higher privileges than you may have needed for other apps on your system (such as MS Office apps).  IT departments don't usually like this but that's another issue.

You may need to have Captivate reinstalled while disconnected from the network so that the normal default folder locations and app structure can be established during the procedure.  Rather than using the default locations that are set during install, which are typically buried down inside your user profile, the better way to set it up is to have a couple of specific folders created at the root level of the C drive.  Make sure these folders are not inside one another.

Once Captivate has been installed correctly and is working without crashing, you can connect back up to the network and see if it works more reliably without having to use your roaming profile.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 16, 2018 1
New Here ,
Oct 17, 2018

Copy link to clipboard

Copied

Hello,

Once again thank you for your reply.

Obviously it would be easiest if we could set this outside the program.

But your response provided a different approach we can look into implementing towards the future.

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 17, 2018 0
RodWard LATEST
Adobe Community Professional ,
Oct 17, 2018

Copy link to clipboard

Copied

I suggested that approach because having the default locations on a roaming profile might NOT be the only thing that is not right.  Fixing that alone might not get you anywhere.

Although Captivate IS used by corporate users all around the world, the way IT depts set up their systems can be very varied.  IT loves to control everything and have all sorts of stuff safely stashed away on their protected servers.  Unfortunately, Captivate was more designed with an individual user in mind rather than trying to cater to the plethora of possible configurations and permission levels that an IT network might be set up with.

So, removing the IT network from the equation and getting Captivate set up as if it were just a standalone system is one way to get things working again.

With the reinstall though, make sure you also clear the Preferences and delete the Layouts folder in your user profile in order to get a proper clean install.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 17, 2018 0