• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't Turn On Body Tracker

Contributor ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

I imported a puppet into my scene and dragged it onto the timeline. The "Body" behavior has a red dot next to it. But The Body Tracker button in the Camera & Microphone panel cannot be selected and remains grey. Can this be fixed?

TOPICS
Camera

Views

861

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

Can you confirm that you have the Body behavior in the root of your puppet's hierarchy? Also, check out this thread for how to use body tracking: Feature Focus: Body Tracker - Adobe Support Community - 12043365

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

Here's a screen shot.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

The image indicates that you have no camera installed. Is that correct?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

By default, that puppet does not have the body behavior for body tracking installed. To install it, you need to go into rig mode, click on the plus symbol as seen in the image below, and select "Body" from the menu. Then your puppet will be able to use body tracking. 

Willy.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

The body tracker will be disabled in the camera panel if you do not have a camera connected, or the camera is disabled. Based on the screenshot, it looks like the app is not recognizing your webcam. Once you get your PC and the Character Animator app to recognize your webcam, try clicking the camera icon as in the image if nothing still shows up there.

character animator-01.jpg

 

@TheOriginalGC 

You do not need the body behavior attached to your puppet to turn on the body tracking, though in practice it does not make sense to turn it on without a body-trackable puppet.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

I am testing out this program on 2 computers. The screen shot is from my desktop, which has no camera. On my laptop I did what you said and added the Body behavior, but when I calibrated it by standing with my arms down, the iamge stretched vertically!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

It stretches because you moved (most likely up in the camera image space) from where you calibrated at.

Try recalibrating if you move around again.

My recommendation is to try to keep the same distance from the camera during your performance.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

Sorry, I'm very new at this. I calibrated it 5 times and each time it stretches. I am standing perfectly still and I am visible from above my head to my wrists.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2023 Mar 23, 2023

Copy link to clipboard

Copied

LATEST

Aside from the stretch (I cannot reproduce the issue), I realize that Willie is not set up for body tracking.

 

The Willie puppet available here https://www.okaysamurai.com/puppets/ has the Face behavior renamed to "Body" which is confusing because it will not do the body tracking but only do the face tracking.

 

You can easily make it ready for body tracking by the following steps:

1. In the Rig mode, add the real "Body" behavior to Willie

Screenshot 2023-03-23 at 5.58.30 PM.png

2. In the Triggers panel, double-click on the "hips" arm pose to turn it off so it will not conflict with the body tracking

jsaito_0-1679623007417.png

 

I can share my version of Willie if you have trouble doing this yourself.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines