• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

xxx.cfm files will not load

Participant ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

I have a new Windows 2019 server running CF21.

I moved my main site, and intranet, over and all went well.

I added an additional site, and extranet, and cfm pages will not load.

I created an index.cfm page that displays simple text and the current date.

https://harvardtransfusion.partners.org/ displays correctly

https://harvardtransfusion.partners.org/index.cfm gives a 404 error.

Any thoughts on what I need to do to correct this?  Please be kind as I am not a programmer, but a Blood Banker.  🙂

Thank you

Views

745

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jul 08, 2021 Jul 08, 2021

Yes, bloodbanker. I suspect you need a step for the new site you added, and it should be fairly quick and painless.

 

Are you using iis? I will assume so, since you say you're on Windows. (The same concepts apply to apache, for those using that instead, whether on Windows or Linux.) 

 

Look at your working intranet site in the iis ui, expand it to list its folders. You will see one there  called jakarta. That's actually a "virtual" directory (vd) that got put there by the cf web server configura

...

Votes

Translate

Translate
Community Expert ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

Yes, bloodbanker. I suspect you need a step for the new site you added, and it should be fairly quick and painless.

 

Are you using iis? I will assume so, since you say you're on Windows. (The same concepts apply to apache, for those using that instead, whether on Windows or Linux.) 

 

Look at your working intranet site in the iis ui, expand it to list its folders. You will see one there  called jakarta. That's actually a "virtual" directory (vd) that got put there by the cf web server configuration tool (wsconfig) , which you or someone else there used to set things up before. Now look at the not-working extranet site. Is it missing that jakarta vd?

 

If so, it may be as simple as creating a new one by hand. Let me explain.

 

The virtual directory will point to to an isapi_redirect.dll file. You can see its full path by right-clicking on the jakarta vd, then choose "manage virtual directory" then "advanced settings". Copy the path shown at the top.

 

You may get by by simply creating a new jakarta vd in the extranet site. Right-click the site and choose "add virtual directory", with the name jakarta and the path/filename you copied.

 

Try your site. Does it work now? If so, great. It means that someone used cf's web server config (wsconfig) tool to connect "all sites" in iis to cf, and that set things up so that the needed settings to talk to cf (things in iis called isapi filters and handler mappings) got setup at the "server" level in iis. New sites inherit those. But there is no iis mechanism for a new iis site to inherit virtual directories that way, thus the need to create it manually.

 

If this approach does NOT work, it may instead be that whoever ran the wsconfig tool setup the intranet site separately, and did NOT set things up for "all sites". In that case, it would be best to remove that vd you added, then run the wsconfig tool instead and point it at your extranet site. But that's not something I'll detail here. It's in the cf docs.

 

And there's still more I could say, but let's see if this gets you going. I know many wish for one-paragraph answers. For some problems that's just not possible. 🙂 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 08, 2021 Jul 08, 2021

Copy link to clipboard

Copied

I do not mind the paragraphs long explanation.  I greatly appreciate the time you took to help me and the thorough explanation.

I created the vd and pointed the path to the one the main site is using, all is well.

https://harvardtransfusion.partners.org/index.cfm works correctly now.

Thank you!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 09, 2021 Jul 09, 2021

Copy link to clipboard

Copied

LATEST

Wonderful to hear, and glad to have helped. Hope it may help future readers as well. 


/Charlie (troubleshooter, carehart.org)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Documentation