Creative Cloud on Windows 11

New Here ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

Hello, I have downloaded and installed Creative Cloud on a new Windows 11 laptop and it won't load. I get a message about it taking longer than usual and it never actually opens.

Views

78

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 14, 2022 Mar 14, 2022

Copy link to clipboard

Copied

Let me move this to the Creative Cloud Services forum for you, where I think you are more likely to get a good answer for your question.

The Using the Community forum is for help in using the Adobe Support Community forums, not for help with specific programs, installation issues, or account issues such as subscription questions or billing problems, or generalized questions about Creative Cloud services.

* Product questions should be posted in the associated product community.
* Installation questions should be posted in the Download & Install community.
* Account issues, including subscription questions or billing problems, should be posted in the Account, Payment, & Plan community.
* Questions about the Creative Cloud desktop app or general questions about apps in the Creative Cloud should be posted to the Creative Cloud Services community.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2022 Mar 28, 2022

Copy link to clipboard

Copied

LATEST

I had a similar problem with a brand new Windows 11 PC right out of the box.  After a bit of digging, I discoverd a problem with a few missing or corrupted .dll files.  Installed Microsoft Visual C++ Redistributable from https://docs.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170  That seemed to fix the problem for me temporarily until another product I was installing installed another version of C++.  But running the previous C++ package download again seemed to fix the problem again.  

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines