Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Dimensions no shadow showing on rendered image?

Community Beginner ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

Hi there,

I have uploaded an OBJ file and used my own photo of a background that is indoors with no windows. I have matched the objects to the background. I have turned off the sunlight effect to create the shadows I want from the image. The shadow opacity is at 100% and shows in the design window. However, the shadows are not showing in the render preview. I have also tried rendering to see if this appears and sadly it does not.

Does anyone have any idea on how to fix this? I am unable to post pictures on here due to confidentiality.

thanks,

Views

2.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 14, 2018 May 14, 2018
Use the Render Preview as the source of truth when changing your lighting settings.  The canvas in design mode is not accurate.  To turn on the render preview you can click the button above the canvas or use the default shortcut key "\"

Likes

Translate

Translate
Adobe Employee ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

Use the Render Preview as the source of truth when changing your lighting settings.  The canvas in design mode is not accurate.  To turn on the render preview you can click the button above the canvas or use the default shortcut key "\"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

Hi there,

thanks for your help.

I am using the preview and the shadow are not showing here either. Though on the design it is very prominent. Not sure if there is something else I can do as the images look flat on the background at the moment? Even with the shadow showing at 100% there is still nothing on the preview?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

That's what I mean though.  The render preview is correct.  The canvas preview is incorrect.  Ignore anything you see in the design mode canvas, it's designed to be very fast so you can interact in real time, but generating realistic lighting and shadows can't be done instantly, so it's just a very quick preview.  The render preview takes a little longer to update but gives you a realistic preview.  You should have the render preview window open while making changes to your lighting and design for the render preview results, not for the canvas.

I'd have to see your scene and settings to be able to make specific recommendations about lighting.  You can share a link to your .dn file via Google Drive, Dropbox, CC Assets, etc. and I can take a look if you'd like.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2019 Dec 16, 2019

Copy link to clipboard

Copied

Hi, I think I might be experiencing a bug. When I open my old file that rendered correctly last week, the shadows are perfect but if I click on anything, absolutely anything, the render preview changes in the canvas and my shadows disappear. I've even rendered a few times with different shadow opacity's and they all come out the same so I know there is something going on. Please help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

I had to post a new question for the same issue. Hope we get a solution. What I'm doing is adding the shadows in Photoshop. 
I use the Dimension design preview for reference to match opacity, angle, etc. Pretty easy.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

I now see the problem for me. On a darker background, the shadow can appear extremely faint even though the design preview is quite dark. The solution is to beef up the shadow darkness/contrast in the rendered PSD file layer. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

LATEST

had the issue it was driving me nets. but it was the shadow opacity...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines