• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Objects aren't casting shadows when rendered or in render preview

Community Beginner ,
Mar 09, 2018 Mar 09, 2018

Copy link to clipboard

Copied

I see shadows in the main viewport. When I rotate my light, they rotate accordingly. However, shadows aren't appearing at all on surfaces in the render preview or on final render.

Any ideas?

Views

963

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 09, 2018 Mar 09, 2018

The main canvas/viewport is only a very rough preview designed to be fast, but it is not accurate for many things including glass, translucency, reflections, and shadows.  Be sure to turn on the render preview in design mode (default shortcut is \ )when finalizing your design before doing a final render in render mode.  As you can see from this screenshot the render preview looks pretty different and is much closer to the actual final render.  Previewing the render takes some CPU and battery tho

...

Likes

Translate

Translate
LEGEND ,
Mar 09, 2018 Mar 09, 2018

Copy link to clipboard

Copied

add a different background image (with lights, sun etc) then put the original back in

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 09, 2018 Mar 09, 2018

Copy link to clipboard

Copied

- Happens to me too. Sometimes, when I apply a background, and I use Match Image, the sun light is not triggered because the program understands that there is no need. When we want to force more shadow, we activate sun light.

- You may also be applying a light style that emits a lot of light from all sides, which will cause a decrease in the shadows. Try to activate the sunshine and set the height and cloudiness.

- See if the ground plane is on. If it is not, it will not show the shadows.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 09, 2018 Mar 09, 2018

Copy link to clipboard

Copied

LATEST

The main canvas/viewport is only a very rough preview designed to be fast, but it is not accurate for many things including glass, translucency, reflections, and shadows.  Be sure to turn on the render preview in design mode (default shortcut is \ )when finalizing your design before doing a final render in render mode.  As you can see from this screenshot the render preview looks pretty different and is much closer to the actual final render.  Previewing the render takes some CPU and battery though so we close it by default.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines