• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Mouse Fails When DreamWeaver is Running

Community Beginner ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

I have a Mac Pro and fully up-to-date Dreamweaver with a Majic Mouse 1.

 

My mouse works just fine at all times on all applications until Dreamweaver is running.  As soon as Dreamweaver is running and I am focussed on the Dreamweaver application, it almost grinds to a a complete halt.  It freezes, stops moving, jumps randomly and is generaly almost wholly unusable.

 

I've tried a different non-Apple mouse and get the same result.

Views

468

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

You say they work fine until DW is running. What other app(s) are you running before you launch DW?  If you close those app(s), does DW behave normally, or is the mouse issue still noticeable?  If the mouse issue is still noticeable, can you try logging in via another user account on the computer (even a guest account) and see if the error can be reproduced there to rule out user profile corruption on the OS level?   

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

Other apps are just boring things like Apple Mail, Safari etc.

 

There is no problem when I am using those apps, only when using Dreamweaver and it is the in-focus app, and it happens even when Dreamweaver is the only app running on the machine.

 

It almost seems like Dreamweaver is so busy doing 'something' in the background that it is grinding the general UI to a halt.

 

I also use Photoshop and Illustrator quite often, and there are no problems with these apps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

Try connecting a different mouse and see if that helps.

Turn off syncing in DW to see if that helps.

 

Apple Magic Accessories help

https://support.apple.com/en-us/HT204621

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

I checked out syncing, and it's not enabled.  I was getting confused in a different comment between syncing and automatic upload on save.  I have this enabled.

I think it's better (but still not great) if I delete the testing server from my site configuration and just work with the remote server only.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

Which OS?

Which version of DW?

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

macOS Big Sur 11.4

DW 21.1

I also suspect it is something to do with syncing.  I like this feature and I don't want to turn it off, but I'll give it a go and see what happens.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

Also, it's a 3.5 GHz 6-Core Mac Pro with 16GB RAM, so this is a pretty decent machine.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 19, 2021 Jun 19, 2021

Copy link to clipboard

Copied

This behavior also occurs under Windows. There are dozens of different threads that report the same erratic behavior of Dreamweaver, which has major performance issues, hangs, freeze, etc... it happens in ways that are complicated to determine.


It is known that some do not have this problem.


Adobe has noticed it several times by taking control of my own machine, logs have been sent, crash reports galore... nothing has been done to find out, what was hapening under cover...


precision... at the same time as these behaviors are noted, Sublime Text, Note Pad++, Ultra Edit... they on their side, function completely normally.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

I think I have found the issue...

 

The problem disapears when I only have one server associated to the site.  It happens when I have 2 servers linked - remote and testing.  If I only have remote, then it's Ok.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 20, 2021 Jun 20, 2021

Copy link to clipboard

Copied

@SewerSleuth,

I use a local testing server for PHP/MySQL development without any problems.

  • Win10, (version 2004 with latest updates)
  • DW CC 2021,
  • Wamp Server.

 

Which local testing server do you have?

Is testing server properly defined in DW with your local site folder residing inside the testing server's default web directory on your primary hard drive?

 

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Sorry, I'm not enough of an expert to understand what you're talking about.

I have access to two ftp locations on the same domain for two different reasons but not the domain site root, so I have them both setup in my sites panel, but DW won't let them both be a remote server.  One of them has to be a testing server.  I'm not testing anything with it, just using it as a ftp connection, but removing this from the servers area of the sites panel against my connection improves the situation many times over.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

LATEST

I see.  So you have corrupted your site definition.  Delete it.

Create two new site definitions, one for each site.

     -- Site A at remote location 1

     -- Site B at remote location 2.

 

That should take care of the mouse problem.

 

Automatic upload on SAVE is dangerous.  I don't care how careful you are, it's just a bad workflow. 

  • Use Ctrl/Cmd + S to save.
  • Preview in your local browser to ensure everything works as expected first.
  • Use Ctrl/Cmd + Shift + U to upload the open document to remote server.  Or upload files by hitting the UP arrow in your Files Panel (F8).

 

I work with database driven content (PHP/MySQL).  Synchronizing my local site folder with the remote server would have devastating consequences. So I NEVER use that option.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines