• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

movie player not displaying pause on autoplay

Contributor ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

a minor glitch--

 

If you select any movie on this page https://toddheymandirector.com/reel/

 

the movie automatically (correctly) begins playing.. however the play icon continues to be displayed. It should be the pause icon since it is playing. If you click on the play icon,  the play icon stays, which is correct because youve paused it. if you click it again and begins plays and finally displays the pause icon which is correct because its playing.

 

how do i get it to display the pause icon when the page loads and it is playing? a pseudo class for the onload state?

 

here is the css for the player from the player stylesheet https://toddheymandirector.com/css/video-js3.css

* Play/Pause
--------------------------------------------------------------------------------
*/
.vjs-default-skin .vjs-play-control {
width: 25px;
cursor: pointer;
color: #d38d48;
}
.vjs-default-skin .vjs-play-control:before {
content: "\i";
margin-top:8px;
}
.vjs-default-skin.vjs-playing .vjs-play-control:before {
content: "\g";
font-size: 25px;
margin-top:8px;

}

Views

162

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

CSS makes things look pretty.  JavaScript makes them function. 

 

I assume you're using Video.js?  Please refer to your player's documentation:

https://docs.videojs.com/

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

i did look there Nancy - i can only find the documentation on autoplay not the button that gets displayed when it begins playing..  i feel like its a glitch not a choice..no?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

To be honest, I've never used it and have no idea what it supports.

You might reach out to the developers and ask them.

 

Nancy O'Shea— Product User, Community Expert & Moderator
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

thanks Nancy - I sent them a message!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

I would suspect an artifact between the erratic handling of autoplay by browser support and user control options, which may or may not cause some consideration of this.

 

Here at the studio, a test on FF does not launch the playback of the videos, it requires an explicit click

anyway, concerning this particular point, there is an article on MDN that is quite explicit

https://developer.mozilla.org/en-US/docs/Web/Media/Autoplay_guide

 

Similarly on the videojs site, some blog pages address this subject, FWIT it could be interesting to follow their advice by not using HTML attributes but a real explicit launch from a set of instructions. unless you are already doing that, I didn't inestigate your code

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

LATEST

in addition the videos, and their photographs, present on your site are superb, bravo for this work

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines